Bug 367981 - reduce load during graceful restart
reduce load during graceful restart
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: httpd (Show other bugs)
5.0
All Linux
low Severity low
: ---
: ---
Assigned To: Joe Orton
:
: 466205 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-06 03:19 EST by Joe Orton
Modified: 2009-01-20 16:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:07:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Orton 2007-11-06 03:19:08 EST
Description of problem:
Current 2.2.x releases use a "GET /" request to wake up children during a
graceful restart; this may cause unnecessary load by causing dynamic page
generation, or by activating a reverse proxy request to a backend.

This has been switched to using "OPTIONS *" upstream for such requests, and 
providing a streamlined "OPTIONS *" implementation which doesn't hit mainline
request processing.

Version-Release number of selected component (if applicable):
2.2.3-11.el5

How reproducible:
always

1. service httpd graceful
2. see lots of "GET /" in mod_status output
Comment 1 RHEL Product and Program Management 2007-12-03 15:47:26 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release.  This request will
be reviewed for a future Red Hat Enterprise Linux release.
Comment 2 RHEL Product and Program Management 2008-06-02 16:29:10 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 5 Joe Orton 2008-10-09 04:21:15 EDT
*** Bug 466205 has been marked as a duplicate of this bug. ***
Comment 8 errata-xmlrpc 2009-01-20 16:07:49 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0185.html

Note You need to log in before you can comment on or make changes to this bug.