Bug 368261 - sos do not get stuck on dead-IO
sos do not get stuck on dead-IO
Status: CLOSED DUPLICATE of bug 657372
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: sos (Show other bugs)
5.5
All Linux
high Severity low
: ---
: ---
Assigned To: Adam Stokes
:
: 394761 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-06 09:10 EST by Navid Sheikhol-Eslami
Modified: 2011-01-14 12:01 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-14 12:01:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Navid Sheikhol-Eslami 2007-11-06 09:10:06 EST
Description of problem:

A common problem of sysreport and SoS is that it would hang whenever a processes
requested I/O on a dead device.

SoS now has a configurable time-out for each command, after which it will stop
waiting for a process and continue (trying to SIGKILL the child process, if
possible).

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:

SoS waits (sometimes forever) for its child.

Expected results:

SoS continues and generates a report, even if partial.

Additional info:
Comment 1 Navid Sheikhol-Eslami 2007-11-22 05:16:08 EST
*** Bug 394761 has been marked as a duplicate of this bug. ***
Comment 2 Navid Sheikhol-Eslami 2007-11-22 05:25:39 EST
*** Bug 374751 has been marked as a duplicate of this bug. ***
Comment 3 Bryn M. Reeves 2007-11-26 05:01:32 EST
This bug is talking about dead devices but there are numerous other ways that
sos or the tools it runs can end up blocking. E.g. bug 394761 is about lsof &
stuck NFS mounts - depending on the mount options that are used, a SIGKILL is
not going to help there.
Comment 4 Bryn M. Reeves 2007-11-26 05:06:28 EST
When sosreport is stuck like this, issuing Ctrl-C produces a message that
suggests it will terminate, but this again hangs:

 Progress [###################100%##################][6682:11/6682:11]
SIGTERM received, multiple threads detected, waiting for all threads to exit
Comment 5 Navid Sheikhol-Eslami 2007-11-26 07:58:17 EST
The fix mentioned in this BZ implements a time-out: when that is reached a
SIGKILL is sent to the child process and the plugin continues. Even if SIGKILL
is unsuccessful, the plugin returns allowing sos to continue.

-- Navid
Comment 9 Bryn M. Reeves 2011-01-14 12:01:46 EST
Closing this dup of bug 657372; the other bugzilla is more general (although the problem itself is still more general again) and has more information.

*** This bug has been marked as a duplicate of bug 657372 ***

Note You need to log in before you can comment on or make changes to this bug.