Bug 368351 - RHEL4 U6: usb test does not detect plugged in device
RHEL4 U6: usb test does not detect plugged in device
Status: CLOSED ERRATA
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
5
All Linux
low Severity low
: ---
: ---
Assigned To: Greg Nichols
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-06 10:11 EST by Greg Nichols
Modified: 2008-07-16 17:57 EDT (History)
0 users

See Also:
Fixed In Version: RHBA-2008-0033
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-15 10:25:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
all files attached. (1.26 MB, application/x-gzip)
2008-01-11 00:52 EST, Satyabrata Maitra
no flags Details

  None (edit)
Description Greg Nichols 2007-11-06 10:11:50 EST
Description of problem:

For RHEL 4, the usb test does not detect usb devices when 
they are plugged in as requested.

Version-Release number of selected component (if applicable):

HTS 5.1 R12, RHEL 4 U6

How reproducible:

Allways.
Comment 1 Greg Nichols 2007-11-06 10:12:46 EST
Actually, it's HTS 5.1 R11.
Comment 2 Greg Nichols 2007-11-27 10:16:12 EST
Fixed R13
Comment 4 Satyabrata Maitra 2008-01-04 04:16:26 EST
I attempted to test this bug, but faced a problem creating hts plan for a
particular arch - ia64 El4.6-AS system. Bug filed and URL given below.

https://bugzilla.redhat.com/show_bug.cgi?id=427339
Comment 5 Greg Nichols 2008-01-04 08:56:40 EST
You won't be able to run the USB test in a guest environment, as you have
attempted in 427339.  You need to run the test on a direct RHEL 4 U6 install.
Comment 7 Satyabrata Maitra 2008-01-09 01:38:16 EST
Hi Greg

I have something to explain about my comment in #4 and your comment in #5.

First of all, I did not use guest environment or virtual system. I used an ia64
system with EL4-U6, full installation. And obviously it was with remote access
with ssh as, this system is in Brisbane!

And in Comment #4, my concern was "unable to create test plan for ia64 system',
Not "the USB test issue on it". 

Because, if the test plan can not be created, none of the tests can be run.

So, now my queries are as follows :-
If the system-under-test is remotely placed to me, and installed with Full
EL4-U6 (not in guest environment), and I am having the access on it via ssh, and
there is somebody who can assists me to ensure that there is at least one USB
device attached in the system, Can I run USB testing for hts there? I should,
and the test also should PASS, if I put the right information during testing
like "how many usb devise attached" etc. 

Actually this was the scenario I followed when attempted to test USB on EL4-U6
system, but It FAILED to create test plan, and I had to postpone my test,
because without Test Plan, I can't proceed to run any tests. 

Please inform your suggestions.
Comment 9 Greg Nichols 2008-01-09 07:19:02 EST
You can not run the USB test remotely, as you need to be able to insert and
remove physical USB devices.

You can not run the USB test in a guest OS install.

Comment 10 Satyabrata Maitra 2008-01-11 00:52:32 EST
Created attachment 291353 [details]
all files attached.
Comment 11 Satyabrata Maitra 2008-01-11 00:59:57 EST
Tested this bug on ia64 system with EL4-U6.
This bug is fixed now.
Its now detecting the plugged in usb devices and its ports during testing. Both
the usb test and associated info test are PASS.

Version of the component Tested :
hts-5.1-18
Arch :- ia64 (Not guest Environment)
O.S : EL4-U6

Additional Information :- All the .xml files, .log files, .rpm files and other
related files are attached in .tar file above in comment #10. 

i created a hardware certification also with its result .rpm file. Certification
number is 265513.
Comment 14 errata-xmlrpc 2008-02-15 10:25:29 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0033.html

Note You need to log in before you can comment on or make changes to this bug.