Bug 36839 - util-linux 2.11a-* breaks Ctrl-C
util-linux 2.11a-* breaks Ctrl-C
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: util-linux (Show other bugs)
1.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Erik Troan
David Lawrence
:
: 36840 39237 40225 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-20 10:46 EDT by Bernhard Rosenkraenzer
Modified: 2005-10-31 17:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-06 16:46:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bernhard Rosenkraenzer 2001-04-20 10:46:09 EDT
Ctrl-C doesn't stop processes after updating to util-linux 2.11a anymore.
Comment 1 Bernhard Rosenkraenzer 2001-05-03 09:31:42 EDT
*** Bug 36840 has been marked as a duplicate of this bug. ***
Comment 2 dunwoody 2001-05-06 16:41:37 EDT
*** Bug 39237 has been marked as a duplicate of this bug. ***
Comment 3 dunwoody 2001-05-06 16:46:36 EDT
I reported Bug 39237, which I have now reported as a duplicate of this bug.  The
problem is a regression
in /bin/login that happened sometime between util-linux-2.10s-8 and
util-linux-2.11a-4.  I noticed the problem when I updated from Rawhide 20010310
(including util-linux-2.10s-8) to Rawhide 20010503
(including util-linux-2.11a-4).   I was able to eliminate the problem on my
otherwise purely
Rawhide 20010503 system by changing the single file /bin/login back to the
20010310 version of
/bin/login from util-linux-2.10s-8.
Comment 4 Bernhard Rosenkraenzer 2001-05-07 12:20:55 EDT
Fixed in 2.11b-1
Comment 5 Bill Crawford 2001-05-08 13:11:05 EDT
Is there any chance you could make this fix available from people.redhat.com or
somewhere?  It breaks more than just ^C, anything using /dev/tty is broken e.g.
"vlock -a" currently doesn't work.  I rely on this to securely lock my
workstation here (xlock has some bugs, I don't like xscreensaver).
Comment 6 Bernhard Rosenkraenzer 2001-05-08 13:28:30 EDT
http://www.linux-easy.com/rh-updates/
Comment 7 Bill Crawford 2001-05-08 14:02:16 EDT
Aha!  Many thanks ... I'll bookmark this!
Comment 8 Bernhard Rosenkraenzer 2001-05-11 16:22:44 EDT
*** Bug 40225 has been marked as a duplicate of this bug. ***
Comment 9 dunwoody 2001-07-06 11:18:35 EDT
I just updated to Rawhide 20010701, including util-linux-2.11f-1, and this
problem seems to still
exist in 2.11f-1.
Comment 10 Bill Crawford 2001-07-20 10:19:21 EDT
Yes, this seems to have b0rken again.  It's not working for me in
rawhide-release-20010713 either.
Comment 11 Wagner T. Correa 2001-10-25 03:33:56 EDT
It seems that this problem reappeared in util-linux-2.11f-11.7.1.
It's not always reproducible, though. Sometimes Ctrl-C works, sometimes it
doesn't...
Comment 12 Wagner T. Correa 2001-11-07 02:42:06 EST
The problem still appears in util-linux-2.11f-12 once in a while.
Comment 13 Need Real Name 2001-11-28 20:29:41 EST
I reliably reproduce "bash: no job control in this shell" using RedHat 7.2
with util-linux-2.11f-12.  Every time I telnet from an identically configured
machine to the target machine as a regular user, then "su", I see:
  bash: no job control in this shell
Comment 14 Bill Crawford 2001-11-29 05:20:05 EST
Sounds like a race condition?

Anyway, I've seen a recurrence of the problem, symptom is dropping right back to
the login prompt when I log out of GNOME.  This was with the latest Raw Hide
kernel.

Note You need to log in before you can comment on or make changes to this bug.