Bug 36878 - using apxs to install modules breaks apache
Summary: using apxs to install modules breaks apache
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: apache   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-20 19:39 UTC by nolan
Modified: 2007-04-18 16:32 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-13 18:43:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description nolan 2001-04-20 19:39:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-2 i686)


because of the apache config file in /etc madness, when apxs adds the line
"LoadModule foo_module lib/apache/mod_foo.so" to httpd.conf, apache tries
to look for the modules relative to /conf's parent directory (in this case,
/etc/httpd).

You've got a modules symlink, which unfortunately doesn't help, given
apxs's choice of paths.

The solution is quite simple.  I made a symlink in /etc/httpd called 'lib'
that points to '/usr/lib'.  The obvious alternative solution is to hack
apxs to use a path that fits with the modules symlink already in
/etc/httpd.

Reproducible: Always
Steps to Reproduce:
1. apxs -i -a apache_module.so
2. start apache


Actual Results:  apache failed to load the module, as it couldn't find it.	

Expected Results:  apache should have found and loaded the module.

Comment 1 Dan Browning 2001-05-04 15:54:23 UTC
FYI, I just ran into the same problem, and I was glad to find this bug (now I 
don't have to report it ;-).  Kijiki0's fix worked for me as well:

ln -s /usr/lib /etc/httpd/lib

I suppose an errata apache-devel is in order, eh?  

Thanks for the great software and hard work, Red Hat engineers!

Comment 2 Nalin Dahyabhai 2001-07-24 19:12:17 UTC
Setting the execprefix to /usr while setting the prefix to /etc/httpd seems to
fix this weirdness with apxs.  It'll be folded into a pending errata of 1.3.20
and into Raw Hide.

Comment 3 David Morse 2003-02-13 18:43:22 UTC
Confirmed fixed in apache-1.3.27-2.  apxs now correctly adds the /usr prefix to 
the LoadModule line.


Note You need to log in before you can comment on or make changes to this bug.