Bug 368811 - winbindd: request_len_recv: Invalid request size received: 2084 (expected 2088)
winbindd: request_len_recv: Invalid request size received: 2084 (expected 2...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
7
All Linux
low Severity high
: ---
: ---
Assigned To: Simo Sorce
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 274531
  Show dependency treegraph
 
Reported: 2007-11-06 14:53 EST by Helge Deller
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-08 14:06:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Helge Deller 2007-11-06 14:53:39 EST
Description of problem:
We just updated to samba-common-3.0.26a-6.fc7, and now the syslog fills up 
every 40 seconds with:

Nov  6 20:50:01 ls3163 winbindd[11705]: [2007/11/06 20:50:01, 0] 
nsswitch/winbindd.c:request_len_recv(544)
Nov  6 20:50:01 ls3163 winbindd[11705]:   request_len_recv: Invalid request 
size received: 2084 (expected 2088)
Nov  6 20:50:01 ls3163 winbindd[11705]: [2007/11/06 20:50:01, 0] 
nsswitch/winbindd.c:request_len_recv(544)
Nov  6 20:50:01 ls3163 winbindd[11705]:   request_len_recv: Invalid request 
size received: 2084 (expected 2088)
Nov  6 20:50:01 ls3163 winbindd[11705]: [2007/11/06 20:50:01, 0] 
nsswitch/winbindd.c:request_len_recv(544)
Nov  6 20:50:01 ls3163 winbindd[11705]:   request_len_recv: Invalid request 
size received: 2084 (expected 2088)
Nov  6 20:50:01 ls3163 winbindd[11705]: [2007/11/06 20:50:01, 0] 
nsswitch/winbindd.c:request_len_recv(544)
Nov  6 20:50:01 ls3163 winbindd[11705]:   request_len_recv: Invalid request 
size received: 2084 (expected 2088)


Version-Release number of selected component (if applicable):
samba-common-3.0.26a-6.fc7
Comment 1 Guenther Deschner 2007-11-06 19:32:07 EST
Sorry for asking but have you actually restarted winbindd/rebooted the machine
after installing the update?
Comment 2 Helge Deller 2007-11-07 06:02:31 EST
Yes, I did restarted winbindd.  No reboot, but this shouldn't be necessary 
either.
Comment 3 Simo Sorce 2007-11-08 10:03:11 EST
Winbindd and libnss_winbindd are intimately connected.
if you don't reboot you have at least to restart all services that make NSS
calls as the glibc do not reload libnss libraries when they are upgraded.

If the command getent passwd <username> returns correctly, then I would advise a
reboot (or a restart of all services).

Please report if getent passwd <username> fails (producing on of those output
lines in the log, or a restart does not fix the issue.
Comment 4 Helge Deller 2007-11-08 13:50:15 EST
getent works without problems (I tried a few accounts, incl. NIS and Win-ADS):

[root@ls3163 NXClient]# getent passwd d036493
d036493:XXXX:10000:17:Helge Deller:/sapmnt/home1/d036493:/bin/bash
Comment 5 Simo Sorce 2007-11-08 14:06:07 EST
Ok in this case it is just that you need a reboot/service restart, it is not a bug.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.