Bug 368861 - (Dunwell) Suspected gnuplot RPM built with FC 6 - causes failure
Suspected gnuplot RPM built with FC 6 - causes failure
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gnuplot (Show other bugs)
5.1
i386 Linux
low Severity high
: ---
: ---
Assigned To: Frantisek Kluknavsky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-06 15:30 EST by dunwell
Modified: 2013-03-07 09:03 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-07 09:03:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description dunwell 2007-11-06 15:30:15 EST
Description of problem:
when using gnuplot 4.0 patchlevel 0, the most current version from RH when using
yum to update, one can issue the command
  set term png size 960,480
and it will fail with something like
   expecting: {small, medium, large},[no]transparent, or {monochrome,
    gray, color, [xRRGGBB] }

Some searching around on the web seems to imply that others think that if the
RPM is built with FC6 and their png driver,  rather than the GD-based PNG
driver, that this error occurs.

------ web clip ---------
XXXX@gmail.com wrote:
>  I am using gnuplot 4.0 with FC 6.

That's your problem right there.  The makers of FC 6, for reasons only
they can tell you, decided to build their gnuplot-4.0 RPM with the wrong
PNG driver.

> expecting: {small, medium, large},[no]transparent, or {monochrome,
> gray, color, [xRRGGBB] }

Build your own gnuplot using the GD-based PNG driver, and/or complain to
the packager about this.
--------- end web clip ----


Version-Release number of selected component (if applicable):
RHEL5 with gnuplot 4.0 patchlevel 0

How reproducible:
always

Steps to Reproduce:
1. I have a plot file that looks like
> cat cost_graph.gplot 
set term png
set term png size 960,480
set output "/tmp/cost_graph.png"
set key left top
set title "Cost Graph - Tue Nov  6 10:46:50 2007"
set xlabel "Time"
set ylabel "Money Saved - $"
set yrange [0:89.8123]
set xtics ("09/2007" )
set grid
plot "/tmp/cost_graph.dat" using 1:2 with lines lw 3 ti "Running Total"

2.I call the plot with
   gnuplot ./cost_graph.gplot
3.
  
Actual results:
> gnuplot ./cost_graph.gplot

gnuplot> set term png size 960,480
                      ^
         "./cost_graph.gplot", line 2: expecting: {small, medium,
large},[no]transparent, or {monochrome, gray, color, [xRRGGBB] }



Expected results:
Expected to get a file called cost_graph.png created.

Additional info:
Comment 1 dunwell 2007-11-06 16:35:15 EST
Further detailed digging shows that this is most likely a backward compatibility
issue with gnuplot 4.0. Look at
   http://www.gnuplot.info/docs/node32.html
and
   http://www.gnuplot.info/docs/node31.html#set_term_size

It seems that it is related to the ./configure command mentioned there. I don't
quite understand their notation of the form
   set term 5#5terminal_type6#6 size 5#5XX6#6, 5#5YY6#6 
when their example shows
   set term pbm size 600, 400
but that is a notation issue.

In any case, it might be nice if the current RPM for gnuplot was moved to the
4.2 release to address this and offered with/without the 
   ./configure --disable-backwards-compatibility
configuration modes.
Comment 2 dunwell 2007-11-12 12:46:12 EST
varekova@redhat.com,

Any thoughts on this. I'm kind of stuck here and can't proceed till I get
gnuplot working. If I need to build it myself I need to know.

Please advise,
Alan D.
Comment 3 dunwell 2007-11-26 09:58:02 EST
Well, this was a total waste of time, I won't bother with Bugzilla again.
Comment 4 RHEL Product and Program Management 2011-09-22 20:31:38 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 5 RHEL Product and Program Management 2012-06-11 21:16:22 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 6 Frantisek Kluknavsky 2013-03-07 09:03:33 EST
Can not reproduce. Works with RHEL-5.9

Note You need to log in before you can comment on or make changes to this bug.