Bug 368901 - Static on macbook pro with kernel 2.6.23.1-21
Static on macbook pro with kernel 2.6.23.1-21
Status: CLOSED DUPLICATE of bug 380991
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-06 15:58 EST by Ryan Schlesinger
Modified: 2008-01-15 22:36 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-15 22:36:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
scsconfig.log (49.23 KB, text/plain)
2007-11-06 15:58 EST, Ryan Schlesinger
no flags Details

  None (edit)
Description Ryan Schlesinger 2007-11-06 15:58:36 EST
Description of problem: 
After upgrading to kernel-2.6.23.1-21.fc7 on a second gen macbook pro, there is
a constant static/popping in the left channel audio.  Also, the volume controls
are strange: the surround control is used to control attached speakers while
both the front and surround controls are used to control the onboard speakers
(used to be main/master and front).


Version-Release number of selected component (if applicable):
This was observed in Fedora 7 running kernel-2.6.23.1-21.fc7.

How reproducible:
Always.

Steps to Reproduce:
1. Boot the laptop.
2. Play sound.
  
Actual results:
Static/popping in right channel.  Volume controls incorrect.

Expected results:
Sound should play without distortion.  Volume controls should be less confusing.

Additional info:
This effectively breaks sound playback for me.  scsconfig.log attached.
Comment 1 Ryan Schlesinger 2007-11-06 15:58:36 EST
Created attachment 249601 [details]
scsconfig.log
Comment 2 Ryan Schlesinger 2007-11-06 16:02:07 EST
For clarification, the static is in the left channel as first stated in the bug
report.  Sorry for the confusion.
Comment 3 Ryan Schlesinger 2007-11-08 16:28:30 EST
Confusingly, after I booted into windows last night and booted linux again, the
distortion is gone.
Comment 4 Ryan Schlesinger 2007-11-13 16:15:06 EST
I've filed a bug against Fedora 8 for this issue.  See bug 380991.
Comment 5 Christopher Brown 2008-01-15 22:36:11 EST

*** This bug has been marked as a duplicate of 380991 ***

Note You need to log in before you can comment on or make changes to this bug.