Bug 369011 - Tokend fails on OS X Leopard.
Tokend fails on OS X Leopard.
Status: CLOSED ERRATA
Product: Red Hat Certificate System
Classification: Red Hat
Component: ESC (Show other bugs)
7.3
All Mac OS
urgent Severity high
: ---
: ---
Assigned To: Jack Magne
:
Depends On:
Blocks: 445047 512842
  Show dependency treegraph
 
Reported: 2007-11-06 16:53 EST by Timothy J. Miller
Modified: 2010-06-01 15:43 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-01 15:43:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Timothy J. Miller 2007-11-06 16:53:13 EST
Description of problem:
Tokend doesn't run on OS X Leopard.  This seems to be part of a generalized Leopard compatibility 
problems.


Version-Release number of selected component (if applicable):
coolkey 1.1.0

How reproducible:
Always.

Steps to Reproduce:
1. Install Leopard.
2. Install Smart Card Manager.
3. Attempt to work.  :)
  
Actual results:
coolkey.tokend sometimes launches, sometimes doesn't, always dies without taking control of the card.  

Expected results:
It should work.

Additional info:
ESC has problems too; will open separate bug.
Comment 1 Timothy J. Miller 2007-11-06 17:00:23 EST
Also note:  Since tokend doesn't run, keychain never appears in Keychain Access.
Comment 2 Bob Relyea 2007-11-06 20:12:23 EST
Another tokend issue.
Comment 3 Jack Magne 2007-11-26 17:02:03 EST
Was able to get this working experimentally by doing the following:

1. Enrolling a Gemalto 64K Token.
2. The problem seems to be that the BELPIC tokenD and the CoolKey tokenD can get
in a state where they are fighting over each other for PCSCD.
3. Temporarily move the CoolKey tokenD from
/System/Library/Security/tokend/A_COOLKEY.tokend to ..../tokend/Z_COOLKEY.tokend.

This at least allows the tokend to launch and work ok. Further investigation
into why will continue.
Comment 5 Jack Magne 2010-04-16 17:22:07 EDT
How To Test:

1. Install the latest ESC for Mac.

2. Enroll a token.

3. Remove the enrolled token and re-insert it into the computer.

4. This should activate the COOLKEY.tokend process.

5. If everything is working, "ps -fe" should reveal a "COOLKEY" process.

6. The ID of the token should also show up as a KeyChain. To check this, open the app "/Applications/Utilities/Keychain Access". Clicking upon the entry for this keychain should reveal the list of certificates and keys contained within the token.
Comment 7 Asha Akkiangady 2010-05-26 11:31:36 EDT
Tested the steps in comment #5, enrolled token insertion event activate the COOLKEY.tokend process. 

"/Applications/Utilities/Keychain Access" shows the certificates and keys on the token.


Marking the bug verified.
Comment 8 errata-xmlrpc 2010-06-01 15:43:04 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0448.html

Note You need to log in before you can comment on or make changes to this bug.