Bug 369261 - pv guest SDL console window can't be closed on shutdown
pv guest SDL console window can't be closed on shutdown
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.1
ia64 Linux
low Severity low
: ---
: ---
Assigned To: Xen Maintainance List
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-06 18:44 EST by Amy Griffis
Modified: 2009-12-14 16:25 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-21 10:43:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Amy Griffis 2007-11-06 18:44:24 EST
Description of problem:

Often after shutting down a paravirt guest, the SDL console window remains and
can't be closed normally.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. configure a pv guest to use SDL graphics
2. start the guest
3. shut down the guest, any method (virt-manager, xm, shutdown in the guest)
  
Actual results:
At least half of the time, the X window used for the SDL console won't close
normally. You can close the window with xkill.

Expected results:


Additional info:
I don't see this on i386. It looks like an ia64-only problem.
Comment 1 Chuck Morrison 2008-08-19 17:37:50 EDT
I have attempted to reproduce this on ia64 (HP BL870c) without success on rhel5.2 using the SDL that is packaged with RHEL5.2.

I have shut down the pv domU several times with each of the following methods:  virt-manager, 
xm, 
poweroff, 
and "shutdown -h now"

The SDL window disappeared as expected in each case.

The only difference from the original report I can think of is that I was running X apps (and thus both virt-manager and the SDL domU) remotely via ssh -Y, not on a locally connected monitor.

I suggest closing this bug as fixed unless it needs to be tested via a direct connection.
Comment 2 Rick Hester 2008-08-21 10:43:18 EDT
Closing per Chuck's comment.

Note You need to log in before you can comment on or make changes to this bug.