Bug 36979 - [2.2.19-7.0.1]emu10k sound driver doesn't provide bass or treble controls anymore
Summary: [2.2.19-7.0.1]emu10k sound driver doesn't provide bass or treble controls any...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-21 14:12 UTC by Manfred Hollstein
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-05 08:44:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Manfred Hollstein 2001-04-21 14:12:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.2.19-7.0.1 i686)


The emu10k sound driver contained in the latest upgrade kernel doesn't
allow to tailor bass or
treble levels anymore; this results in REALLY poor quality of the generated
sound.
Some further investigation reveals that all related code is wrapped in
#ifdef TONE_CONTROL ...
#endif in drivers/sound/emu10k/{main,mixer.c}, without any location where
this is actually
enabled/defined. I rebuilt the emu10k.o module using a patch, which you can
find at

 
<http://www.cygnus.com/~manfredh/rhl7.0/linux-2.2.19-emu10k-tone_control.patch>

and which fixed the problem for me on my SoundBlaster Live! Player 1024.

FWIW, this seems to be related with an entry for 2.4 kernels of RHL 7.1;
see

  <http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=32723>

Reproducible: Always
Steps to Reproduce:
1.Boot system with 2.2.19-7.0.1 kernel and a sound card with an EMU10K chip
included
2.Start sound mixer application
3.Look for any controls for bass or treble
	

Actual Results:  There are no controls available.

Expected Results:  Two sliders (one for bass and one for treble) are
available with 2.2.17-14 (and with my patch
applied on 2.2.19 as well;-) )

Comment 1 Manfred Hollstein 2002-05-05 08:44:47 UTC
This report can be closed, as current versions in RHL 7.2 and 7.3 can utilize
the emu10k1 driver and tools from <http://sourceforge.net/projects/emu10k1>
to enable treble/bass controls.

Comment 2 Michael K. Johnson 2002-05-06 22:39:39 UTC
Thanks for the note!


Note You need to log in before you can comment on or make changes to this bug.