Bug 369841 - xmlrpc-c: 1.12 available
xmlrpc-c: 1.12 available
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xmlrpc-c (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Enrico Scholz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-07 11:27 EST by Chris Weyl
Modified: 2008-03-19 00:03 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-27 08:44:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Weyl 2007-11-07 11:27:37 EST
xmlrpc-c 1.12 is available.

I know you're trying to stick to the stable branch, but it would be very useful
to have the "advanced" branch available to build against as well, for those
packages which require it (e.g. RPC::Xmlrpc_c.)
Comment 1 Chris Weyl 2007-11-08 00:30:14 EST
Just to add to this, it looks like cmake is the only package in Fedora that
depends on xmlrpc-c:

[cweyl@athena ~]$ apt-cache whatdepends xmlrpc-c
xmlrpc-c-1.06.11-2.fc7
  xmlrpc-c-devel.32bit-1.06.11-2.fc7
    Depends: xmlrpc-c = 1.06.11-2.fc7
      xmlrpc-c.32bit-1.06.11-2.fc7
  xmlrpc-c-devel-1.06.11-2.fc7
    Depends: <libxmlrpc_cpp.so.3()(64bit)>
      xmlrpc-c-1.06.11-2.fc7
    Depends: <libxmlrpc_client++.so.3()(64bit)>
      xmlrpc-c-1.06.11-2.fc7
    Depends: <libxmlrpc++.so.3()(64bit)>
      xmlrpc-c-1.06.11-2.fc7
    Depends: <libxmlrpc_server_cgi.so.3()(64bit)>
      xmlrpc-c-1.06.11-2.fc7
    Depends: <libxmlrpc_server_abyss.so.3()(64bit)>
      xmlrpc-c-1.06.11-2.fc7
    Depends: <libxmlrpc_server_abyss++.so.3()(64bit)>
      xmlrpc-c-1.06.11-2.fc7
    Depends: <libxmlrpc_server.so.3()(64bit)>
      xmlrpc-c-1.06.11-2.fc7
    Depends: <libxmlrpc_client.so.3()(64bit)>
      xmlrpc-c-1.06.11-2.fc7
    Depends: <libxmlrpc.so.3()(64bit)>
      xmlrpc-c-1.06.11-2.fc7
    Depends: <libxmlrpc_abyss.so.3()(64bit)>
      xmlrpc-c-1.06.11-2.fc7
    Depends: <libxmlrpc_util.so.3()(64bit)>
      xmlrpc-c-1.06.11-2.fc7
    Depends: <libxmlrpc_server++.so.3()(64bit)>
      xmlrpc-c-1.06.11-2.fc7
    Depends: xmlrpc-c = 1.06.11-2.fc7
      xmlrpc-c.32bit-1.06.11-2.fc7
  xmlrpc-c-1.06.11-2.fc7
    Depends: <libxmlrpc_client++.so.3()(64bit)>
      xmlrpc-c-1.06.11-2.fc7
  cmake-2.4.6-4.fc7
    Depends: <libxmlrpc_util.so.3()(64bit)>
      xmlrpc-c-1.06.11-2.fc7
  xmlrpc-c-apps-1.06.11-2.fc7
    Depends: <libxmlrpc_util.so.3()(64bit)>
      xmlrpc-c-1.06.11-2.fc7
Comment 2 Enrico Scholz 2007-11-08 03:30:09 EST
ok; I will update xmlrpc-c in the devel branch in the next days
Comment 3 ajayr 2008-02-18 01:23:07 EST
(In reply to comment #2)
> ok; I will update xmlrpc-c in the devel branch in the next days

Enrico,
Any progress with this? I have 1.13.06 compiled from source working fine along
with libtorrent, rtorrent & the php gui for rtorrent, I wait for the day I can
use these apps with a rpm package.

Thanks
Ajay
Comment 4 Enrico Scholz 2008-02-27 08:44:56 EST
ok; 1.13.07 is now in devel branch.  But upstream does not make it easy because
it does not provide tarballs for the 'advanced' series :(
Comment 5 ajayr 2008-03-17 04:11:21 EDT
(In reply to comment #4)
> ok; 1.13.07 is now in devel branch.  But upstream does not make it easy because
> it does not provide tarballs for the 'advanced' series :(

There is some problem in your xmlrpc-c-config make-cmake-transition.patch. When
i build the sources with ./configure etc I am able to build rtorrent with
xmlrpc-c support but when I use your rpm it does not build.

I suspect the changes made to /usr/bin/xmlrpc-c-config are causing the problems,
can you please look into that?

Thanks & best regards
Ajay
Comment 6 Enrico Scholz 2008-03-17 16:09:01 EDT
can you try it again with 1.13.8-2, please?
Comment 7 ajayr 2008-03-19 00:03:04 EDT
(In reply to comment #6)
> can you try it again with 1.13.8-2, please?

yes looks good here - now I can request a bump of rtorrent.

checking for i686-redhat-linux-gnu-pkg-config... no
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for STUFF... yes
checking for XMLRPC-C... ok
checking if compiler supports __attribute__((unused))... yes
configure: creating ./config.status
config.status: creating Makefile

Note You need to log in before you can comment on or make changes to this bug.