Bug 369901 - Software Updater failed
Software Updater failed
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum-rhn-plugin (Show other bugs)
5.0
i686 Linux
low Severity low
: ---
: ---
Assigned To: Mike Orazi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-07 12:04 EST by Victor Liu
Modified: 2008-09-18 14:12 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-21 17:17:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Victor Liu 2007-11-07 12:04:21 EST
Description of problem:
Software Updater failed with error:
Component: Software Updater
Summary: TB9536d0ca <string>:64:__iter__:SyntaxError: not well-formed (invalid
token): line 21895, column 66

Traceback (most recent call last):
  File "/usr/sbin/pup", line 668, in ?
    main()
  File "/usr/sbin/pup", line 664, in main
    pup.run()
  File "/usr/sbin/pup", line 499, in run
    self.doRefresh()
  File "/usr/sbin/pup", line 324, in doRefresh
    self.populateUpdates()
  File "/usr/sbin/pup", line 380, in populateUpdates
    self.updateMetadata.add(repo)
  File "/usr/lib/python2.4/site-packages/yum/update_md.py", line 235, in add
    for event, elem in iterparse(infile):
  File "<string>", line 64, in __iter__
SyntaxError: not well-formed (invalid token): line 21895, column 66

Local variables in innermost frame:
b: <TreeBuilder object at 0x9ec0ad8>
self: <iterparse object at 0x9e43fcc>
event: ('end', <Element 'updated' at 0xa99e788>)
p: <XMLParser object at 0x9d3e080>
data: e
was assigned a page directory page (cr3) greater than 4 GB, a crash session
initialization failure indicating "crash: cannot read/find cr3 page" would
occur. The snapshot value in the dump file header in the updated crash
packages allows page directory pages greater than 4 GB.

* crash reported the namelist and dumpfile "do not match!" when viewing a
core dump from a fully-virtualized xen guest running on AMD64. There was no
support for determining the physical base address of xen dump files so
crash, incorrectly, defaulted to a physical base address of zero. These
updated crash packages add support for determining the physical base
address of relocatable AMD64 kernels when run as a fully-virtualized xen
guests.

* earlier versions of the "bt" command caused a segmentation violation when
run against x86 xen-syms-xxx namelist files captured with kdump. With this
update the issue no longer occurs.

This update also adds the following enhancements:

* more reliable "bt" command backtraces for AMD64.

* a crash-devel package for extension modules has been added. It installs
defs.h in /usr/include/crash.

Users of the crash packages should apply this update, which resolves these
issues and adds these enhancements.</description>
    <references>
       <reference
href="http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=233151" id="233151"
type="bugzilla">
        crash fails to read RHEL-5 FV core dump files collected from xm dump-core
      </reference>
       <reference
href="http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=241045" id="241045"
type="bugzilla">
        need crash-devel package for building extensions
      </reference>
    </references>
    <pkglist>
      <collection short="rhel-i386-client-5">
        <name>Red Hat Enterprise Linux Desktop (v. 5 for 32-bit x86)</name>
          <package name="crash-devel" version="4.0" release="4.6.1" epoch="0"
arch="ppc64" src="crash-4.0-4.6.1.src.rpm">
            <filename>crash-devel-4.0-4.6.1.ppc64.rpm</filename>
            <sum type="md5">38a8d88874206e3bc44ab886c3a2a497</sum>
          </package>
          <package name="crash-devel" version="4.0" release="4.6.1" epoch="0"
arch="i386" src="crash-4.0-4.6.1.src.rpm">
            <filename>crash-devel-4.0-4.6.1.i386.rpm</filename>
            <sum type="md5">61f62c514eab94b520161d7a248da749</sum>
          </package>
          <package name="crash" version="4.0" release="4.6.1" epoch="0"
arch="i386" src="crash-4.0-4.6.1.src.rpm">
            <filename>crash-4.0-4.6.1.i386.rpm</filename>
            <sum type="md5">4aba5561748b201a79c07ceac9114333</sum>
          </package>
          <package name="crash-devel" version="4.0" release="4.6.1" epoch="0"
arch="ia64" src="crash-4.0-4.6.1.src.rpm">
            <filename>crash-devel-4.0-4.6.1.ia64.rpm</filename>
            <sum type="md5">a9ab391d8197e432c6fee0efa5b76cc3</sum>
          </package>
          <package name="crash" version="4.0" release="4.6.1" epoch="0"
arch="x86_64" src="crash-4.0-4.6.1.src.rpm">
            <filename>crash-4.0-4.6.1.x86_64.rpm</filename>
            <sum type="md5">4f1db6a7d3472e88bce862c28df157b0</sum>
          </package>
          <package name="crash" version="4.0" release="4.6.1" epoch="0"
arch="ppc64" src="crash-4.0-4.6.1.src.rpm">
            <filename>crash-4.0-4.6.1.ppc64.rpm</filename>
            <sum type="md5">b879f039f72878fef807fa06b7cf230a</sum>
          </package>
          <package name="crash-devel" version="4.0" release="4.6.1" epoch="0"
arch="x86_64" src="crash-4.0-4.6.1.src.rpm">
            <filename>crash-devel-4.0-4.6.1.x86_64.rpm</filename>
            <sum type="md5">5929757af45c6d1283d76da63929685b</sum>
          </package>
          <package name="crash" version="4.0" release="4.6.1" epoch="0"
arch="s390x" src="crash-4.0-4.6.1.src.rpm">
            <filename>crash-4.0-4.6.1.s390x.rpm</filename>
            <sum type="md5">b64b42a6862c775646ba0251db9b465d</sum>
          </package>
          <package name="crash-devel" version="4.0" release="4.6.1" epoch="0"
arch="s390x" src="crash-4.0-4.6.1.src.rpm">
            <filename>crash-devel-4.0-4.6.1.s390x.rpm</filename>
            <sum type="md5">588912f0c7a9b817093a0b23801e34be</sum>
          </package>
          <package name="crash-devel" version="4.0" release="4.6.1" epoch="0"
arch="s390" src="crash-4.0-4.6.1.src.rpm">
            <filename>crash-devel-4.0-4.6.1.s390.rpm</filename>
            <sum type="md5">626e14fe32d8b0239d6a6f1e3d6b9c28</sum>
          </package>
          <package name="crash" version="4.0" release="4.6.1" epoch="0"
arch="ia64" src="crash-4.0-4.6.1.src.rpm">
            <filename>crash-4.0-4.6.1.ia64.rpm</filename>
            <sum type="md5">8b5f9a36750c0ca13103bc9e81d86a0c</sum>
          </package>
      </collection>
    </pkglist>
  </update>  <update from="security@redhat.com" status="final" type="bugfix"
version="4">
    <id>RHBA-2007:0563-4</id>
    <title>RHBA-2007:0563</title>
    <issued date="2007-11-07 10:25:55"/>
    <updated date="2007-11-07 10:25:55"/>
    <description>quagga bug fix update

Quagga manages the TCP/IP based routing protocol. It takes multi-server and
multi-thread approaches to resolve the current complexity of the Internet.
Quagga supports BGP4, BGP4+, OSPFv2, OSPFv3, RIPv1, RIPv2, and RIPng.
Quagga is intended to be used as a Route Server and a Route Reflector.

This update fixes the following bug:

* initscripts were found to not be LSB compliant.

This update also adds the following enhancement:

* enable updating the source address of a route for VIPA


All users of quagga should upgrade to these updated packages, which resolve
this issue and add this feature.</description>
    <references>
       <reference
href="http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=243143" id="243143"
type="bugzilla">
        Wrong init script
      </reference>
       <reference
href="http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=249302" id="249302"
type="bugzilla">
        Init script in quagga errata 2007:0563 needs a few fixes & improvements
      </reference>
    </references>
    <pkglist>
      <collection short="rhel-i386-client-5">
        <name>Red Hat Enterprise Linux Desktop (v. 5 for 32-bit x86)</name>
          <package name="quagga-contrib" version="0.98.6" release="5.el5"
epoch="0" arch="x86_64" src="quagga-0.98.6-5.el5.src.rpm">
            <filename>quagga-contrib-0.98.6-5.el5.x86_64.rpm</filename>
            <sum type="md5">86f8b59baea26d3654f0222c82bea422</sum>
          </package>
          <package name="quagga-devel" version="0.98.6" release="5.el5"
epoch="0" arch="x86_64" src="quagga-0.98.6-5.el5.src.rpm">
            <filename>quagga-devel-0.98.6-5.el5.x86_64.rpm</filename>
            <sum type="md5">b2c6e6fc3ebb0a1c54278674faea3e06</sum>
          </package>
          <package name="quagga-devel" version="0.98.6" release="5.el5"
epoch="0" arch="ia64" src="quagga-0.98.6-5.el5.src.rpm">
            <filename>quagga-devel-0.98.6-5.el5.ia64.rpm</filename>
            <sum type="md5">10d101f4608ea0286a765591566b8f9f</sum>
          </package>
          <package name="quagga-devel" version="0.98.6" release="5.el5"
epoch="0" arch="i386" src="quagga-0.98.6-5.el5.src.rpm">
            <filename>quagga-devel-0.98.6-5.el5.i386.rpm</filename>
            <sum type="md5">bfc7e690edc675a36af8bd146e61b8cb</sum>
          </package>
          <package name="quagga-contrib" version="0.98.6" release="5.el5"
epoch="0" arch="i386" src="quagga-0.98.6-5.el5.src.rpm">
            <filename>quagga-contrib-0.98.6-5.el5.i386.rpm</filename>
            <sum type="md5">52c5c8da2e2acc43e14a80ad7b384fb3</sum>
          </package>
          <package name="quagga" version="0.98.6" release="5.el5" epoch="0"
arch="x86_64" src="quagga-0.98.6-5.el5.src.rpm">
            <filename>quagga-0.98.6-5.el5.x86_64.rpm</filename>
            <sum type="md5">696556b7768212716ed78105e1e466ab</sum>
          </package>
          <package name="quagga" version="0.98.6" release="5.el5" epoch="0"
arch="ppc" src="quagga-0.98.6-5.el5.src.rpm">
            <filename>quagga-0.98.6-5.el5.ppc.rpm</filename>
            <sum type="md5">d49794faef60f311b005d602adff7e02</sum>
          </package>
          <package name="quagga" version="0.98.6" release="5.el5" epoch="0"
arch="i386" src="quagga-0.98.6-5.el5.src.rpm">
            <filename>quagga-0.98.6-5.el5.i386.rpm</filename>
            <sum type="md5">4429bf935776ff62af2a7d8d93b14ba5</sum>
          </package>
          <package name="quagga-devel" version="0.98.6" release="5.el5"
epoch="0" arch="ppc64" src="quagga-0.98.6-5.el5.src.rpm">
            <filename>quagga-devel-0.98.6-5.el5.ppc64.rpm</filename>
            <sum type="md5">a76622cd919df964486e653df3aa7cfa</sum>
          </package>
          <package name="quagga" version="0.98.6" release="5.el5" epoch="0"
arch="ia64" src="quagga-0.98.6-5.el5.src.rpm">
            <filename>quagga-0.98.6-5.el5.ia64.rpm</filename>
            <sum type="md5">9045d577c208dc9f71bd42fec736c8e5</sum>
          </package>
          <package name="quagga-contrib" version="0.98.6" release="5.el5"
epoch="0" arch="s390x" src="quagga-0.98.6-5.el5.src.rpm">
            <filename>quagga-contrib-0.98.6-5.el5.s390x.rpm</filename>
            <sum type="md5">e25248939179b231fd042d2ed86405fa</sum>
          </package>
          <package name="quagga-contrib" version="0.98.6" release="5.el5"
epoch="0" arch="ia64" src="quagga-0.98.6-5.el5.src.rpm">
            <filename>quagga-contrib-0.98.6-5.el5.ia64.rpm</filename>
            <sum type="md5">79ffef837b4eb166d83dcddeb05bc61f</sum>
          </package>
          <package name="quagga-devel" version="0.98.6" release="5.el5"
epoch="0" arch="s390" src="quagga-0.98.6-5.el5.src.rpm">
            <filename>quagga-devel-0.98.6-5.el5.s390.rpm</filename>
            <sum type="md5">0b889ff3bf38803720a0fb14ca624eed</sum>
          </package>
          <package name="quagga-contrib" version="0.98.6" release="5.el5"
epoch="0" arch="ppc" src="quagga-0.98.6-5.el5.src.rpm">
            <filename>quagga-contrib-0.98.6-5.el5.ppc.rpm</filename>
            <sum type="md5">cb5406b5a7091d8a60d4003c5656b3d3</sum>
          </package>
          <package name="quagga-devel" version="0.98.6" release="5.el5"
epoch="0" arch="s390x" src="quagga-0.98.6-5.el5.src.rpm">
            <filename>quagga-devel-0.98.6-5.el5.s390x.rpm</filename>
            <sum type="md5">71338bbe15f2320e3429024f89021695</sum>
          </package>
          <package name="quagga-devel" version="0.98.6" release="5.el5"
epoch="0" arch="ppc" src="quagga-0.98.6-5.el5.src.rpm">
            <filename>quagga-devel-0.98.6-5.el5.ppc.rpm</filename>
            <sum type="md5">58e21ae5a2c0f95a42a697a113070e3a</sum>
          </package>
          <package name="quagga" version="0.98.6" release="5.el5" epoch="0"
arch="s390x" src="quagga-0.98.6-5.el5.src.rpm">
            <filename>quagga-0.98.6-5.el5.s390x.rpm</filename>
            <sum type="md5">2eff25f46c0c640f6e47fb2aaca615d1</sum>
          </package>
      </collection>
    </pkglist>
  </update>  <update from="security@redhat.com" status="final"
type="enhancement" version="11">
    <id>RHEA-2007:0567-11</id>
    <title>RHEA-2007:0567</title>
    <issued date="2007-11-07 10:25:55"/>
    <updated date="2007-11-07 10:25:55"/>
    <description>openhpi enhancement update

OpenHPI is an open source project created with the intent of providing an
implementation of the SA Forum's Hardware Platform Interface (HPI). HPI
provides an abstracted interface to managing computer hardware, typically
for chassis and rack-based servers. 

The updated packages include the newest version of OpenHPI, 2.8.1. OpenHPI
2.8 includes multiple features and fixes since OpenHPI 2.4 which bring
OpenHPI into conformance with the SA Forum's specification.

It includes critical bugs fixed in the HPI library with regards to
conformance and other issues discovered since version 2.4.

OpenHPI also includes feature enhancements in the bladecenter plugin, a
daemonized library (daemon mode is default from version 2.6), hot-swap
management enhancements and persistence of alarms per domain.

Also included is the openhpi snmp subagent. The SNMP subagent exports the
HPI interface to snmp protocol clients.

All users of the openhpi package are encouraged to upgrade to these updated
packages, which resolve various issues and offer several enhancements.</description>
    <references>
       <reference
href="http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=304711" id="304711"
type="bugzilla">
        The openhpi-subagent package got built on non-x86 arch
      </reference>
    </references>
    <pkglist>
      <collection short="rhel-i386-client-5">
        <name>Red Hat Enterprise Linux Desktop (v. 5 for 32-bit x86)</name>
          <package name="openhpi-devel" version="2.8.1" release="2.el5.7"
epoch="0" arch="i386" src="openhpi-2.8.1-2.el5.7.src.rpm">
            <filename>openhpi-devel-2.8.1-2.el5.7.i386.rpm</filename>
            <sum type="md5">70b24752600a4aee7e52a8964e64a823</sum>
          </package>
          <package name="openhpi-devel" version="2.8.1" release="2.el5.7"
epoch="0" arch="ppc" src="openhpi-2.8.1-2.el5.7.src.rpm">
            <filename>openhpi-devel-2.8.1-2.el5.7.ppc.rpm</filename>
            <sum type="md5">66d9a219b709e61e4f99a08051e383ab</sum>
          </package>
          <package name="openhpi-devel" version="2.8.1" release="2.el5.7"
epoch="0" arch="ppc64" src="openhpi-2.8.1-2.el5.7.src.rpm">
            <filename>openhpi-devel-2.8.1-2.el5.7.ppc64.rpm</filename>
            <sum type="md5">cb6f0c24d73d041566a44560ae4fe586</sum>
          </package>
          <package name="openhpi" version="2.8.1" release="2.el5.7" epoch="0"
arch="i386" src="openhpi-2.8.1-2.el5.7.src.rpm">
            <filename>openhpi-2.8.1-2.el5.7.i386.rpm</filename>
            <sum type="md5">ae0cdeb0e20b26c0c748fe8cdfc61983</sum>
          </package>
          <package name="openhpi-devel" version="2.8.1" release="2.el5.7"
epoch="0" arch="x86_64" src="openhpi-2.8.1-2.el5.7.src.rpm">
            <filename>openhpi-devel-2.8.1-2.el5.7.x86_64.rpm</filename>
            <sum type="md5">2a630268f8659b5bfaf5461801623e04</sum>
          </package>
          <package name="openhpi-subagent" version="2.8.1" release="2.el5.7"
epoch="0" arch="x86_64" src="openhpi-2.8.1-2.el5.7.src.rpm">
            <filename>openhpi-subagent-2.8.1-2.el5.7.x86_64.rpm</filename>
            <sum type="md5">b2088dd598cc9b0264418b5891396f14</sum>
          </package>
          <package name="openhpi" version="2.8.1" release="2.el5.7" epoch="0"
arch="s390x" src="openhpi-2.8.1-2.el5.7.src.rpm">
            <filename>openhpi-2.8.1-2.el5.7.s390x.rpm</filename>
            <sum type="md5">e0d02b064001b107dec9cb586c145641</sum>
          </package>
          <package name="openhpi-subagent" version="2.8.1" release="2.el5.7"
epoch="0" arch="i386" src="openhpi-2.8.1-2.el5.7.src.rpm">
            <filename>openhpi-subagent-2.8.1-2.el5.7.i386.rpm</filename>
            <sum type="md5">e87eb685293f6e358555e1322739bd66</sum>
          </package>
          <package name="openhpi" version="2.8.1" release="2.el5.7" epoch="0"
arch="x86_64" src="openhpi-2.8.1-2.el5.7.src.rpm">
            <filename>openhpi-2.8.1-2.el5.7.x86_64.rpm</filename>
            <sum type="md5">7394b353e690faeaf1889040f9422cd0</sum>
          </package>
          <package name="openhpi-devel" version="2.8.1" release="2.el5.7"
epoch="0" arch="s390x" src="openhpi-2.8.1-2.el5.7.src.rpm">
            <filename>openhpi-devel-2.8.1-2.el5.7.s390x.rpm</filename>
            <sum type="md5">419ef51964c54eaece10204769186fab</sum>
          </package>
          <package name="openhpi" version="2.8.1" release="2.el5.7" epoch="0"
arch="s390" src="openhpi-2.8.1-2.el5.7.src.rpm">
            <filename>openhpi-2.8.1-2.el5.7.s390.rpm</filename>
            <sum type="md5">44619a31b0f5d3ff12c634d3b03598db</sum>
          </package>
          <package name="openhpi-devel" version="2.8.1" release="2.el5.7"
epoch="0" arch="s390" src="openhpi-2.8.1-2.el5.7.src.rpm">
            <filename>openhpi-devel-2.8.1-2.el5.7.s390.rpm</filename>
            <sum type="md5">713a7e44ef5039516384bd6984f29a95</sum>
          </package>
          <package name="openhpi" version="2.8.1" release="2.el5.7" epoch="0" arch="
events: [('end', <Element 'description' at 0xa99e7a0>), ('end', <Element
'reference' at 0xa99e7d0>), ('end', <Element 'reference' at 0xa99e7e8>), ('end',
<Element 'references' at 0xa99e7b8>), ('end', <Element 'name' at 0xa99e830>),
('end', <Element 'filename' at 0xa99e860>), ('end', <Element 'sum' at
0xa99e878>), ('end', <Element 'package' at 0xa99e848>), ('end', <Element
'filename' at 0xa99e8a8>), ('end', <Element 'sum' at 0xa99e8c0>), ('end',
<Element 'package' at 0xa99e890>), ('end', <Element 'filename' at 0xa99e8f0>),
('end', <Element 'sum' at 0xa99e908>), ('end', <Element 'package' at
0xa99e8d8>), ('end', <Element 'filename' at 0xa99e938>), ('end', <Element 'sum'
at 0xa99e950>), ('end', <Element 'package' at 0xa99e920>), ('end', <Element
'filename' at 0xa99e980>), ('end', <Element 'sum' at 0xa99e998>), ('end',
<Element 'package' at 0xa99e968>), ('end', <Element 'filename' at 0xa99e9c8>),
('end', <Element 'sum' at 0xa99e9e0>), ('end', <Element 'package' at
0xa99e9b0>), ('end', <Element 'filename' at 0xa99ea10>), ('end', <Element 'sum'
at 0xa99ea28>), ('end', <Element 'package' at 0xa99e9f8>), ('end', <Element
'filename' at 0xa99ea58>), ('end', <Element 'sum' at 0xa99ea70>), ('end',
<Element 'package' at 0xa99ea40>), ('end', <Element 'filename' at 0xa99eaa0>),
('end', <Element 'sum' at 0xa99eab8>), ('end', <Element 'package' at
0xa99ea88>), ('end', <Element 'filename' at 0xa99eae8>), ('end', <Element 'sum'
at 0xa99eb00>), ('end', <Element 'package' at 0xa99ead0>), ('end', <Element
'filename' at 0xa99eb30>), ('end', <Element 'sum' at 0xa99eb48>), ('end',
<Element 'package' at 0xa99eb18>), ('end', <Element 'collection' at 0xa99e818>),
('end', <Element 'pkglist' at 0xa99e800>), ('end', <Element 'update' at
0xa99e728>), ('end', <Element 'id' at 0xa99eb78>), ('end', <Element 'title' at
0xa99eb90>), ('end', <Element 'issued' at 0xa99eba8>), ('end', <Element
'updated' at 0xa99ebc0>), ('end', <Element 'description' at 0xa99ebd8>), ('end',
<Element 'reference' at 0xa99ec08>)]


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Victor Liu 2007-11-08 10:33:09 EST
Hi
I resolved the problem by run yum update manually to update the system.
I can run software updater without error now after installing updates using "yum
update".
Thank you very much
Victor Liu
Comment 2 Mike Orazi 2008-04-21 17:17:19 EDT
Cleaning up BZ.

Note You need to log in before you can comment on or make changes to this bug.