Bug 36991 - can't start PCMCIA service -- invalid parameter param_do_scan
Summary: can't start PCMCIA service -- invalid parameter param_do_scan
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.1
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matt Wilson
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-21 16:05 UTC by Need Real Name
Modified: 2008-08-01 16:22 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-02 14:55:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/sysconfig/pcmcia file (112 bytes, text/plain)
2001-05-01 12:35 UTC, Need Real Name
no flags Details
/etc/sysconfig/pcmcia.rpmnew file (63 bytes, text/plain)
2001-05-01 12:37 UTC, Need Real Name
no flags Details
/etc/sysconfig/hwconf file (2.27 KB, text/plain)
2001-05-16 18:56 UTC, Need Real Name
no flags Details

Description Need Real Name 2001-04-21 16:05:50 UTC
After an upgrade from RH7 to RH7.1 (on a Dell Inspiron 3200), I was unable
to start the pcmcia service.  This is the error message I got:
"starting PCMCIA services:  modules
/lib/modules/2.4.2-4/pcmcia/yenta_socket.o: invalid parameter parm_do_scan
/lib/modules/2.4.2-2/pcmcia/ds.o: init_module: Operation not permitted
Hint : insmod errors can be caused by incorrect module parameters,
including invalid IO or IRQ parameters"

I can fixed this by commenting out or removing this line from
/etc/sysconfig/pcmcia:
PCIC_OPTS=do_scan=0

I did not add this line to the /etc/sysconfig/pcmcia file:  either it was
left over from the previous RH7 install or it was added during the upgrade
to 7.1.

Comment 1 Brent Fox 2001-04-27 21:29:21 UTC
Well, it's important for us to know whether the file was already like that or if
the 7.1 installer did that.  But that's kind of hard to reproduce now...
Do you see a file called /etc/syconfig/pcmcia.rpmsave?

Comment 2 Need Real Name 2001-04-28 14:27:14 UTC
No, I do not have a pcmcia.rpmsave file in /etc/sysconfig/.

I do have a /etc/sysconfig/pcmcia.rpmnew file, but the modification time (Mar
11,pre-7.1) indicates that it's left over from a previous update.


Comment 3 Brent Fox 2001-04-30 16:23:14 UTC
When you say "pre-7.1"...do you mean one of the beta releases for 7.1?  I hope
you weren't trying to upgrade from a beta to the final release...   :)

Comment 4 Need Real Name 2001-04-30 17:40:58 UTC
No.  I upgraded from the regular RH7 release.  I have never installed a RH beta
on this machine.  

I suppose it's possible that an update/errata package for RH7 might have witten
this file, but looking over the list of updates/errata for RH7
(http://www.redhat.com/support/errata/rh7-errata.html), I don't see any likely
candidates.


Comment 5 Brent Fox 2001-04-30 21:35:30 UTC
Ok...can you attach the pcmcia.rpmnew and pcmcia files?  Just curious.

Comment 6 Need Real Name 2001-05-01 12:35:30 UTC
Created attachment 16967 [details]
/etc/sysconfig/pcmcia file

Comment 7 Need Real Name 2001-05-01 12:37:00 UTC
Created attachment 16968 [details]
/etc/sysconfig/pcmcia.rpmnew file

Comment 8 Brent Fox 2001-05-01 16:15:37 UTC
Brock, do we have any of these machines in house?

Comment 9 Brent Fox 2001-05-15 18:36:08 UTC
We don't have a machine like this in our test lab.  Can you attach your
/etc/sysconfig/hwconf file?

Comment 10 Need Real Name 2001-05-16 18:56:38 UTC
Created attachment 18650 [details]
/etc/sysconfig/hwconf file

Comment 11 Matt Wilson 2001-07-02 14:58:09 UTC
This option must have been added by hand.  Since this option was added by hand
it's up to the user to make adjustments in this config file as options to kernel
pcmcia modules change.


Note You need to log in before you can comment on or make changes to this bug.