Bug 36993 - can't boot system with 2.2.16 kernel if kudzu is enabled
Summary: can't boot system with 2.2.16 kernel if kudzu is enabled
Status: CLOSED DUPLICATE of bug 23177
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kudzu
Version: 7.1
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-21 16:20 UTC by Need Real Name
Modified: 2014-03-17 02:20 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2001-04-23 16:02:59 UTC


Attachments (Terms of Use)

Description Need Real Name 2001-04-21 16:20:53 UTC
After an upgrade from RH7 to RH7.1 (Dell Inspiron 3200), I cannot boot the
system with a 2.2.16 kernel (compiled under RH7).  The system hangs during
start-up at this point:
"checking for new hardware"

If I disable kudzu, then I can sucessfully boot the system with the 2.2.16
kernel.

Comment 1 Bill Nottingham 2001-04-23 05:02:24 UTC
If you run kudzu after booting, does it still hang?

If you strace it, where is it hanging?

Comment 2 Need Real Name 2001-04-23 14:54:23 UTC
(1) If I run kudzu after booting, it still hangs.

(2) If I "strace -o filename kudzu" I loose the ouput file when I force a
reboot, so I had to copy the output from the console by hand (ie, I may have
made some mistakes).  Here are the last few lines of output to the console when
I run "strace kudzu":

open ("/etc/modules.conf", O_RDONLY) = 3
stat ("etc/modules.conf", {st_mode=S_IFREG|0644, st_suze=300, ...}) = 0
read (3, "alias parport_lowlevel_p" ..., 300) = 300
close (3) = 0
query_module ("usb-uhci", QM_INFO, 0xbffff920, 16, 135011120) = -1 ENOENT (no
such file or directory)
open ("/dev/null", ORDWR) = 3
fork () = 1568
close (3)
wait4(1568,




Comment 3 Need Real Name 2001-04-23 14:58:01 UTC
Oops, I did make some mistakes:

stat ("etc/modules.conf", {st_mode=S_IFREG|0644, st_suze=300, ...}) = 0

should read

stat ("etc/modules.conf", {st_mode=S_IFREG|0644, st_size=300, ...}) = 0

and 

open ("/dev/null", ORDWR) = 3

should be

open ("/dev/null", O_RDWR) = 3

Comment 4 Bill Nottingham 2001-04-23 15:11:05 UTC
What happens if you run 'modprobe usb-ohci' from the command line?

Comment 5 Need Real Name 2001-04-23 16:02:55 UTC
I can't try this:  On my hardware (Dell Inspiron 3200), if I'm running a 2.2.x
kernel, modprobing the uhci or ohci modules completely locks the system (the
2.4.x kernels, including the stock RH7.1 2.4.2 kernel, work fine on this
machine).  See Bugzilla bug # 23177.

When I boot the 2.2.16 kernel I give the "nousb" option at the lilo prompt.

Comment 6 Bill Nottingham 2001-04-23 16:09:54 UTC
Ah, so this is simply a duplicate of that. (kudzu is loading the configured
usb controller so it can probe the USB bus.)

*** This bug has been marked as a duplicate of 23177 ***

Comment 7 Arjan van de Ven 2001-04-23 16:12:27 UTC
2.2.16 kernels cannot be used in 7.1 at all.

Comment 8 Need Real Name 2001-04-23 16:19:38 UTC
In reply to notting@redhat.com:

Something changed between RH7 and RH7.1.  Under RH7 I ran kudzu and had no
problems (booting 2.2.16. 2.2.18 or 2.4.0 kernels), under RH7.1 the system hangs
when I boot try to boot the 2.2.16 kernel.  Didn't the version of kudzu supplied
with Rh7 probe for the usb controller?

In reply to arjanv@redhat.com:

Sorry -- your comment cannot be true.  I can boot my RH7.1 system with a 2.2.16
kernel and it runs fine, as long as I disable kudzu.


Comment 9 Bill Nottingham 2001-04-23 16:21:04 UTC
probe for: yes
load the module: no


Comment 10 Need Real Name 2001-04-23 16:59:29 UTC
OK, thanks.  

I'll just leave kudzu disabled until the time when I can stop using the 2.2.x
kernels.


Note You need to log in before you can comment on or make changes to this bug.