Bug 36993 - can't boot system with 2.2.16 kernel if kudzu is enabled
can't boot system with 2.2.16 kernel if kudzu is enabled
Status: CLOSED DUPLICATE of bug 23177
Product: Red Hat Linux
Classification: Retired
Component: kudzu (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2001-04-21 12:20 EDT by Need Real Name
Modified: 2014-03-16 22:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-04-23 12:02:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-04-21 12:20:53 EDT
After an upgrade from RH7 to RH7.1 (Dell Inspiron 3200), I cannot boot the
system with a 2.2.16 kernel (compiled under RH7).  The system hangs during
start-up at this point:
"checking for new hardware"

If I disable kudzu, then I can sucessfully boot the system with the 2.2.16
Comment 1 Bill Nottingham 2001-04-23 01:02:24 EDT
If you run kudzu after booting, does it still hang?

If you strace it, where is it hanging?
Comment 2 Need Real Name 2001-04-23 10:54:23 EDT
(1) If I run kudzu after booting, it still hangs.

(2) If I "strace -o filename kudzu" I loose the ouput file when I force a
reboot, so I had to copy the output from the console by hand (ie, I may have
made some mistakes).  Here are the last few lines of output to the console when
I run "strace kudzu":

open ("/etc/modules.conf", O_RDONLY) = 3
stat ("etc/modules.conf", {st_mode=S_IFREG|0644, st_suze=300, ...}) = 0
read (3, "alias parport_lowlevel_p" ..., 300) = 300
close (3) = 0
query_module ("usb-uhci", QM_INFO, 0xbffff920, 16, 135011120) = -1 ENOENT (no
such file or directory)
open ("/dev/null", ORDWR) = 3
fork () = 1568
close (3)

Comment 3 Need Real Name 2001-04-23 10:58:01 EDT
Oops, I did make some mistakes:

stat ("etc/modules.conf", {st_mode=S_IFREG|0644, st_suze=300, ...}) = 0

should read

stat ("etc/modules.conf", {st_mode=S_IFREG|0644, st_size=300, ...}) = 0


open ("/dev/null", ORDWR) = 3

should be

open ("/dev/null", O_RDWR) = 3
Comment 4 Bill Nottingham 2001-04-23 11:11:05 EDT
What happens if you run 'modprobe usb-ohci' from the command line?
Comment 5 Need Real Name 2001-04-23 12:02:55 EDT
I can't try this:  On my hardware (Dell Inspiron 3200), if I'm running a 2.2.x
kernel, modprobing the uhci or ohci modules completely locks the system (the
2.4.x kernels, including the stock RH7.1 2.4.2 kernel, work fine on this
machine).  See Bugzilla bug # 23177.

When I boot the 2.2.16 kernel I give the "nousb" option at the lilo prompt.
Comment 6 Bill Nottingham 2001-04-23 12:09:54 EDT
Ah, so this is simply a duplicate of that. (kudzu is loading the configured
usb controller so it can probe the USB bus.)

*** This bug has been marked as a duplicate of 23177 ***
Comment 7 Arjan van de Ven 2001-04-23 12:12:27 EDT
2.2.16 kernels cannot be used in 7.1 at all.
Comment 8 Need Real Name 2001-04-23 12:19:38 EDT
In reply to notting@redhat.com:

Something changed between RH7 and RH7.1.  Under RH7 I ran kudzu and had no
problems (booting 2.2.16. 2.2.18 or 2.4.0 kernels), under RH7.1 the system hangs
when I boot try to boot the 2.2.16 kernel.  Didn't the version of kudzu supplied
with Rh7 probe for the usb controller?

In reply to arjanv@redhat.com:

Sorry -- your comment cannot be true.  I can boot my RH7.1 system with a 2.2.16
kernel and it runs fine, as long as I disable kudzu.
Comment 9 Bill Nottingham 2001-04-23 12:21:04 EDT
probe for: yes
load the module: no
Comment 10 Need Real Name 2001-04-23 12:59:29 EDT
OK, thanks.  

I'll just leave kudzu disabled until the time when I can stop using the 2.2.x

Note You need to log in before you can comment on or make changes to this bug.