Bug 370091 - New kernel RPM leads to "grubby fatal error: unable to find a suitable template"
New kernel RPM leads to "grubby fatal error: unable to find a suitable template"
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.5
All Linux
low Severity low
: ---
: ---
Assigned To: Prarit Bhargava
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-07 13:33 EST by David Tonhofer
Modified: 2008-05-09 07:54 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-09 07:54:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Tonhofer 2007-11-07 13:33:55 EST
Description of problem:

When running "up2date --update --force" to get the new kernel images,
the message "grubby fatal error: unable to find a suitable template" is
shown on the command line:

--------------8<-------------SNIP-----------------8<---------------
[root@MACHINE]# up2date --update --force

Fetching Obsoletes list for channel: rhel-x86_64-es-4...

Name                                    Version        Rel
----------------------------------------------------------
kernel                                  2.6.9          55.0.12.EL        x86_64
kernel-doc                              2.6.9          55.0.12.EL        noarch
kernel-smp                              2.6.9          55.0.12.EL        x86_64


Testing package set / solving RPM inter-dependencies...
########################################
kernel-2.6.9-55.0.12.EL.x86 ########################## Done.
kernel-doc-2.6.9-55.0.12.EL ########################## Done.
kernel-smp-2.6.9-55.0.12.EL ########################## Done.
Preparing              ########################################### [100%]

Repackaging...
     kernel-doc             ########################################### [100%]

Installing...
   1:kernel-smp             ########################################### [100%]
grubby fatal error: unable to find a suitable template
   2:kernel                 ########################################### [100%]
grubby fatal error: unable to find a suitable template
   3:kernel-doc             ########################################### [100%]

--------------8<-------------SNIP-----------------8<---------------

grub.conf has NOT been updated with lines for the new kernel..

Checking the RPMs yields all-ok:

# rpm --query kernel
kernel-2.6.9-55.0.2.EL
kernel-2.6.9-55.0.6.EL
kernel-2.6.9-55.0.9.EL
kernel-2.6.9-55.0.12.EL

# rpm --query kernel-smp
kernel-smp-2.6.9-55.0.2.EL
kernel-smp-2.6.9-55.0.6.EL
kernel-smp-2.6.9-55.0.9.EL
kernel-smp-2.6.9-55.0.12.EL

# rpm --query kernel-doc
kernel-doc-2.6.9-55.0.12.EL

# rpm --verify kernel-doc
# rpm --verify kernel-smp
# rpm --verify kernel


Version-Release number of selected component (if applicable):

Linux 2.6.9-55.0.2.ELsmp #1 SMP Tue Jun 12 17:58:20 EDT 2007 x86_64 x86_64
x86_64 GNU/Linux

How reproducible:

Happened only once

Additional info:

I would say I shall add the missing grub entries by hand.
Comment 1 Prarit Bhargava 2008-05-06 08:57:06 EDT
I've tried this a few times on a RHEL4 system and cannot reproduce this issue. 
Is it possible that you hand editted the grub.conf file with a strange format?

Could you attach your original grub.conf file?

P.
Comment 2 David Tonhofer 2008-05-06 16:02:15 EDT
Hi,

Sorry for the mess. The problem did not reoccur with subsequent updates. If I
remember correctly the grub.conf contained references to no-longer existing
kernel images, and I removed these during a later cleanup, so that must indeed
have been the problem. Still, the error message "grubby fatal error: unable to
find a suitable template" is very confusing.

Best, 

-- David

Note You need to log in before you can comment on or make changes to this bug.