Bug 37022 - Authorization failures with certain pop servers
Authorization failures with certain pop servers
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: fetchmail (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-21 16:42 EDT by marc.lefranc
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-26 02:26:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description marc.lefranc 2001-04-21 16:42:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-2 i586)


Since the update to RH 7.1, fetchmail cannot get the mail from one of y
mail addresses. it complains about "Authorization failure", Query status=3
(AUTHFAIL)

Reproducible: Always
Steps to Reproduce:
1. fetchmail
2.
3.
	

Actual Results:  1044 $ fetchmail
fetchmail: No mail for XXX at pop3.nordnet.fr
fetchmail: No mail for XXX at pop.free.fr
fetchmail: No mail for XXX at pop.laposte.net
fetchmail: Authorization failure on
mlefranc@libertysurf.fr@pop-fr.libertysurf.net 
fetchmail: Query status=3 (AUTHFAIL)


Expected Results:  fetchmail: No mail for XXX at pop3.nordnet.fr
fetchmail: No mail for XXX at pop.free.fr
fetchmail: No mail for XXX at pop.laposte.net
fetchmail: No mail for XXX at pop-fr.libertysurf.net 


Yes, the user name of the pop account at that provider is
mlefranc@libertysurf.fr, not mlefranc (strange, I know, but this is what I
had to do before the upgrade)

Excerpt from .fetchmailrc:
poll pop.libertysurf.fr with proto POP3
       user "mlefranc@libertysurf.fr" there with password "PASSWORD" is
lefranc here options fetchall

I downgraded to the fetchmail package of 7.0, and everything is back to
normal. Thus there is soemthing the new fetchmail does not like with
provider (the strange address ?)
Comment 1 Michael Schwendt 2001-04-26 02:25:56 EDT
What do you get when you run 'fetchmail -v' on that server?
Does stripping the quotes from the password help?
Comment 2 Nalin Dahyabhai 2001-06-26 02:27:31 EDT
Fetchmail now attempts to be more flexible with regargs to authentication
mechanisms which the server reports it supports.  If you wish to use plain
password authentication, add this to the .fetchmailrc file:

poll pop.libertysurf.fr with proto POP3
       auth password

Then things should proceed as before.

Note You need to log in before you can comment on or make changes to this bug.