Bug 37034 - spec file built by cpanflute is broken
Summary: spec file built by cpanflute is broken
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm-build   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-22 06:49 UTC by Chip Turner
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-22 06:49:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chip Turner 2001-04-22 06:49:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2smp i686)


The spec file generated by cpanflute is broken.  It has:

BuildRequires: perl >= 5.00503
Requires: perl >= 5.00503

which, under perl 5.6.0 fails because the epoch is not listed.  The proper
settings would be:

BuildRequires: perl >= 0:5.00503
Requires: perl >= 0:5.00503

(as discussed in bugs 26009 and 19100)

Reproducible: Always
Steps to Reproduce:
1. Run cpanflute on a tarball from cpan.
	

Actual Results:  It breaks: 
[root@magneto math-gmp]# /usr/lib/rpm/cpanflute
/usr/src/redhat/SOURCES/Digest-MD5-2.13.tar.gz 
error: failed build dependencies:
        perl >= 5.00503 is needed by perl-Digest-MD5-2.13-6
RPM test unpacking failed!


Expected Results:  [root@magneto math-gmp]# /usr/lib/rpm/cpanflute
/usr/src/redhat/SOURCES/Digest-MD5-2.13.tar.gz 
Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.54389
+ umask 022
+ cd /tmp/cpan/junk
(etc)

Comment 1 Jeff Johnson 2001-04-22 08:58:00 UTC
Epoch added to perl dependency in CVS, should be in rpm-4.0.3-0.8 and later.


Note You need to log in before you can comment on or make changes to this bug.