Bug 370371 - Package Updater dies on second run of Software Updater after fresh install
Package Updater dies on second run of Software Updater after fresh install
Status: CLOSED DUPLICATE of bug 369831
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: pirut (Show other bugs)
5.0
All Linux
low Severity urgent
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-07 16:23 EST by Marc Bejarano
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 16:40:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
full exception log (21.27 KB, application/octet-stream)
2007-11-07 16:23 EST, Marc Bejarano
no flags Details

  None (edit)
Description Marc Bejarano 2007-11-07 16:23:16 EST
the first run of Software Updater yesterday took my officemate through the RHN
login and then said something about attaching to an existing asset because the
installation number used didn't have any assets?

anyway, i ran Software Updater today and here's the juiciest part of the output:
===
Component: Software Updater
Summary: TB9536d0ca <string>:64:__iter__:SyntaxError: not well-formed (invalid
token): line 21354, column 66

Traceback (most recent call last):
  File "/usr/sbin/pup", line 668, in ?
    main()
  File "/usr/sbin/pup", line 664, in main
    pup.run()
  File "/usr/sbin/pup", line 499, in run
    self.doRefresh()
  File "/usr/sbin/pup", line 324, in doRefresh
    self.populateUpdates()
  File "/usr/sbin/pup", line 380, in populateUpdates
    self.updateMetadata.add(repo)
  File "/usr/lib/python2.4/site-packages/yum/update_md.py", line 235, in add
    for event, elem in iterparse(infile):
  File "<string>", line 64, in __iter__
SyntaxError: not well-formed (invalid token): line 21354, column 66

Local variables in innermost frame:
b: <TreeBuilder object at 0x1e99f38>
self: <iterparse object at 0x1ab5d10>
event: ('end', <Element 'reference' at 0x30b7b70>)
p: <XMLParser object at 0x243a2d0>
data: ef="http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=233853"
===

full output attached
Comment 1 Marc Bejarano 2007-11-07 16:23:16 EST
Created attachment 250881 [details]
full exception log
Comment 2 Jeremy Katz 2007-11-07 16:40:36 EST

*** This bug has been marked as a duplicate of 369831 ***

Note You need to log in before you can comment on or make changes to this bug.