Bug 37081 - symlink to to /etc/rc.d/init.d is missing to /etc/init.d
symlink to to /etc/rc.d/init.d is missing to /etc/init.d
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-22 14:43 EDT by Kris Buytaert
Modified: 2014-03-16 22:20 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-24 10:53:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kris Buytaert 2001-04-22 14:43:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-2 i686)


I upgraded a RH 6.2 or  6.1 box to RH 7.1,  the machine booted but couldn`t
find the /etc/init.d/functions  file, after booting in single user I could
make a symlink to /etc/rc.d/init.d   

Reproducible: Didn't try

Expected Results:  Clean boot should have occured just as with the upgrades
from 7.0.91 to 7.1
Comment 1 Bill Nottingham 2001-04-23 01:04:56 EDT
any errors around chkconfig or initscripts in /tmp/upgrade.log?

Did both chkconfig & initscripts get updated?
Comment 2 John McMonagle 2001-04-24 09:01:53 EDT
The same happened to me twice.

The common thing I can think of is that cups was installed.

On the first system I just did a new install.

On the second system I  used the first as a reference.
Noticed first that all the symlinks of the directories in /etc/rc.d in ./etc
were wrong.

I renamed the existing links and  made new ones.
[root@john /etc]# ls -l *.bad
init.d.bad:
total 8
lrwxrwxrwx    1 root     root           25 Feb  4 09:07 cups ->
/etc/software/init.d/cups
-rwxr--r--    1 root     root         6073 Apr  3 21:55 sdaemon.sh
 
rc0.d.bad:
total 0
lrwxrwxrwx    1 root     root           25 Feb  4 09:07 K00cups ->
/etc/software/init.d/cups
lrwxrwxrwx    1 root     root           20 Apr  3 21:55 K10sdaemon ->
../init.d/sdaemon.sh
 
rc2.d.bad:
total 0
lrwxrwxrwx    1 root     root           25 Feb  4 09:07 S99cups ->
/etc/software/init.d/cups
lrwxrwxrwx    1 root     root           20 Apr  3 21:55 S99sdaemon ->
../init.d/sdaemon.sh
 
rc3.d.bad:
total 0
lrwxrwxrwx    1 root     root           25 Feb  4 09:07 S99cups ->
/etc/software/init.d/cups
lrwxrwxrwx    1 root     root           20 Apr  3 21:55 S99sdaemon ->
../init.d/sdaemon.sh
 
rc5.d.bad:
total 0
lrwxrwxrwx    1 root     root           25 Feb  4 09:07 S99cups ->
/etc/software/init.d/cups
lrwxrwxrwx    1 root     root           20 Apr  3 21:55 S99sdaemon ->
../init.d/sdaemon.sh
[r

Also initscripts did not update. Still had the one from rh6.2.
I did that manually.
Now works fine.

From upgradelog:

Upgrading initscripts.
/etc/X11/prefdm saved as /etc/X11/prefdm.rpmsave
 
/etc/rc.d/init.d/network saved as /etc/rc.d/init.d/network.rpmsave
 
/etc/rc.d/rc.local created as /etc/rc.d/rc.local.rpmnew
 
/etc/rc.d/rc.sysinit saved as /etc/rc.d/rc.sysinit.rpmsave
 
unpacking of archive failed on file /etc/rc0.d: cpio: unlink failed - Is a
directory
Upgrading chkconfig.
unpacking of archive failed on file /etc/init.d: cpio: unlink failed - Is a
directory 

Just looked at archive of old etc
[john@john etcoldjohn]$ ls -l init.d/
total 8
lrwxrwxrwx    1 root     root           25 Apr 20 18:03 cups ->
/etc/software/init.d/cups
-rwxr--r--    1 root     root         6073 Apr  3 21:55 sdaemon.sh

Looks like cups did it !
rpm of cups -1.1.4-1 did it.

John
Comment 3 Bill Nottingham 2001-04-24 10:53:07 EDT
Yes, that looks like the cups package is broken. I'd be curious to know
if the original reporter had that installed.

Note You need to log in before you can comment on or make changes to this bug.