Bug 370901 - LVM can not find the PVs because qla driver does not findshed to scan the disks.
LVM can not find the PVs because qla driver does not findshed to scan the disks.
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.5
All Linux
low Severity low
: ---
: ---
Assigned To: Red Hat Kernel Manager
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-08 03:23 EST by Zhenyong(Jerry) Jiang
Modified: 2013-07-28 20:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 11:53:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zhenyong(Jerry) Jiang 2007-11-08 03:23:53 EST
Description of problem:

When I startup my RHEL, The rhel will report no such file or directory when
trying to open /dev/vg/lv. ( pv is based on some FC array, qlogic card is
qla2340. )

I find it was caused by: 

The initrd-***-img show us system will load qla2340 and do a lvm scan, 

but in my case, when qla23xx is loaded, it will cost some time to scan the bus
in the background. And in the same time, the lvm will begin to scan the PVs in
the system.

My issue is: LVM can not find the PVs because at this time qla23xx does not
findshed to scan the disks in the FC arrays. 

Version-Release number of selected component (if applicable):


How reproducible:

On a particular system, it is always. And on other machines, maybe not.

Steps to Reproduce:

1. Install a RHEK4U4 i386.

2. Connect with FC array, and use FC disks to create a LV, change /etc/fstab to
auto mount it when booting.

3. Reboot the machine
  
Actual results:

The system will stop booting and goto repaire mode.

Expected results:

It should boot up to runlevel 5/or 3

Additional info:

Is there any options in the /etc/modprobe.conf, So I can run mkinitrd and insert
some seconds delay between modprobe qla23xx and lvm scan.

I will put on some screen shot.

Thank you.
Comment 1 Bill Nottingham 2007-11-08 11:20:38 EST
This is not something that can really be solved at the initscripts level;
there's no syncrhonization mechanism available.
Comment 2 Tom Coughlan 2008-03-19 13:43:55 EDT
(In reply to comment #0)

> 1. Install a RHEK4U4 i386.

Jerry, Have you tried a more recent version of RHEL 4? 

Mike, did we add a workaround for this in a more recent version of RHEL 4? I
know we did in RHEL 5, but that problem was due to a different underlying cause. 
Comment 3 Jiri Pallich 2012-06-20 11:53:51 EDT
Thank you for submitting this issue for consideration in Red Hat Enterprise Linux. The release for which you requested us to review is now End of Life. 
Please See https://access.redhat.com/support/policy/updates/errata/

If you would like Red Hat to re-consider your feature request for an active release, please re-open the request via appropriate support channels and provide additional supporting details about the importance of this issue.

Note You need to log in before you can comment on or make changes to this bug.