Bug 370921 - refcounting in iwl3945 on suspend
refcounting in iwl3945 on suspend
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i686 Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-08 03:42 EST by Kjartan Maraas
Modified: 2008-02-11 08:03 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-11 08:03:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kjartan Maraas 2007-11-08 03:42:44 EST
Description of problem:

Got the following when I tried to suspend this morning:

Nov  8 08:52:14 localhost NetworkManager: <info>  Going to sleep.
Nov  8 08:52:14 localhost NetworkManager: <info>  Bringing down device eth0
Nov  8 08:52:14 localhost NetworkManager: <info>  Bringing down device wlan0
Nov  8 08:52:14 localhost NetworkManager: <info>  Deactivating device wlan0.
Nov  8 08:52:14 localhost NetworkManager: <info>  wlan0: canceled DHCP
transaction, dhclient pid 5895
Nov  8 08:52:14 localhost avahi-daemon[1930]: Interface wlan0.IPv4 no longer
relevant for mDNS.
Nov  8 08:52:14 localhost avahi-daemon[1930]: Leaving mDNS multicast group on
interface wlan0.IPv4 with address 10.0.0.16.
Nov  8 08:52:14 localhost ntpd[1792]: sendto(80.203.242.202) (fd=23): Invalid
argument
Nov  8 08:52:14 localhost kernel: ACPI: PCI interrupt for device 0000:02:00.0
disabled
Nov  8 08:52:14 localhost kernel: iwl3945: Intel(R) PRO/Wireless 3945ABG/BG
Network Connection driver for Linux, 1.1.17kds
Nov  8 08:52:14 localhost kernel: iwl3945: Copyright(c) 2003-2007 Intel Corporation
Nov  8 08:52:14 localhost kernel: ACPI: PCI Interrupt 0000:02:00.0[A] -> GSI 17
(level, low) -> IRQ 17
Nov  8 08:52:14 localhost kernel: iwl3945: Detected Intel PRO/Wireless 3945ABG
Network Connection
Nov  8 08:52:14 localhost avahi-daemon[1930]: Withdrawing address record for
fe80::219:d2ff:fe37:b62c on wlan0.
Nov  8 08:52:14 localhost avahi-daemon[1930]: Withdrawing address record for
10.0.0.16 on wlan0.
Nov  8 08:52:14 localhost NetworkManager: <WARN> 
nm_device_802_11_wireless_get_mode(): error getting card mode on wlan0: No such
device
Nov  8 08:52:14 localhost kernel: BUG: unable to handle kernel NULL pointer
dereference at virtual address 00000000
Nov  8 08:52:14 localhost kernel: printing eip: f8b16333 *pde = 00000000
Nov  8 08:52:14 localhost kernel: Oops: 0000 [#1] SMP
Nov  8 08:52:14 localhost kernel: Modules linked in: iwl3945 mac80211 cfg80211
udf i915 drm arc4 ecb blkcipher rfcomm l2cap nf_conntrack_netbios_ns
nf_conntrack_ipv4 xt_state nf_conntrack nfnetlink xt_tcpudp ipt_REJECT
iptable_filter ip_tables x_tables cpufreq_ondemand acpi_cpufreq dm_mirror dm_mod
ipv6 snd_hda_intel snd_seq_dummy snd_seq_oss snd_seq_midi_event snd_seq
snd_seq_device snd_pcm_oss snd_mixer_oss snd_pcm snd_timer snd_page_alloc
snd_hwdep sr_mod tpm_infineon parport_pc snd irda crc_ccitt cdrom tifm_7xx1
iTCO_wdt tpm hci_usb serio_raw bluetooth parport sdhci mmc_core ata_piix
tifm_core video iTCO_vendor_support ac battery tpm_bios button ata_generic
soundcore output sg tg3 joydev ahci libata sd_mod scsi_mod ext3 jbd mbcache
uhci_hcd ohci_hcd ehci_hcd
Nov  8 08:52:14 localhost kernel: CPU:    0
Nov  8 08:52:14 localhost kernel: EIP:    0060:[<f8b16333>]    Not tainted VLI
Nov  8 08:52:14 localhost kernel: EFLAGS: 00010286   (2.6.23.1-42.fc8 #1)
Nov  8 08:52:14 localhost kernel: EIP is at iwl_verify_inst_sparse+0x254/0x304
[iwl3945]
Nov  8 08:52:14 localhost kernel: eax: 0f802020   ebx: 00000000   ecx: e82ed000
  edx: e7d10e00
Nov  8 08:52:14 localhost kernel: esi: e7d10e00   edi: 00000000   ebp: 00000000
  esp: e82edf0c
Nov  8 08:52:14 localhost kernel: ds: 007b   es: 007b   fs: 00d8  gs: 0000  ss: 0068
Nov  8 08:52:14 localhost kernel: Process iwl3945/0 (pid: 19188, ti=e82ed000
task=ee8a0000 task.ti=e82ed000)
Nov  8 08:52:14 localhost kernel: Stack: 00000000 00000000 c28071d0 00000000
00000000 00000a6c 00000000 e7d10e00
Nov  8 08:52:14 localhost kernel:        e7d147d4 fffffffb 00000000 f8b16455
00000000 c061df0d e7d1132c e7d1132c
Nov  8 08:52:14 localhost kernel:        ee8a0000 e7d11324 e7d147d4 e7d10e00
e7d147d4 f8b1c7cb 00000000 f8b1c843
Nov  8 08:52:14 localhost kernel: Call Trace:
Nov  8 08:52:14 localhost kernel:  [<f8b16455>] iwl_verify_ucode+0x72/0x47a
[iwl3945]
Nov  8 08:52:14 localhost kernel:  [<c061df0d>] __mutex_lock_slowpath+0x52/0x7a
Nov  8 08:52:14 localhost kernel:  [<f8b1c7cb>]
iwl_bg_init_alive_start+0x0/0x521 [iwl3945]
Nov  8 08:52:14 localhost kernel:  [<f8b1c843>]
iwl_bg_init_alive_start+0x78/0x521 [iwl3945]
Nov  8 08:52:14 localhost kernel:  [<f8b1c7cb>]
iwl_bg_init_alive_start+0x0/0x521 [iwl3945]
Nov  8 08:52:14 localhost kernel:  [<c043a4b7>] run_workqueue+0x7d/0x109
Nov  8 08:52:14 localhost kernel:  [<c043d5cf>] prepare_to_wait+0x24/0x3f
Nov  8 08:52:14 localhost kernel:  [<c043ad10>] worker_thread+0x0/0xc4
Nov  8 08:52:14 localhost kernel:  [<c0405dbb>] kernel_thread_helper+0x7/0x10
Nov  8 08:52:14 localhost kernel:  =======================
Nov  8 08:52:14 localhost kernel: Code: db c7 44 24 18 00 00 00 00 eb 39 b8 ab
15 00 00 b9 0c 04 00 00 89 f2 89 1c 24 e8 d8 f5 ff ff 8b 86 38 05 00 00 8b 80 1c
04 00 00 <3b> 45 00 74 0e 47 83 ff 02 77 b6 c7 44 24 18 fb ff ff ff 83 c3
Nov  8 08:52:14 localhost kernel: EIP: [<f8b16333>]
iwl_verify_inst_sparse+0x254/0x304 [iwl3945] SS:ESP 0068:e82edf0c
Nov  8 08:52:15 localhost acpid: received event "thermal_zone TZ0 00000081 00000000"
Nov  8 08:52:15 localhost acpid: notifying client 2027[68:68]
Nov  8 08:52:15 localhost acpid: notifying client 2207[0:0]
Nov  8 08:52:15 localhost acpid: client has disconnected
Nov  8 08:52:15 localhost acpid: completed event "thermal_zone TZ0 00000081
00000000"
Nov  8 08:52:15 localhost ntpd[1792]: sendto(82.148.138.26) (fd=23): Invalid
argument

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Kjartan Maraas 2008-01-21 07:50:06 EST
Someone posted a fix for this on linux-kernel jan. 9 2008. Not sure if that's
been included in the rawhide kernel already, but now I don't get an oops any
more. I still can't suspend though because of some refcounting issues. I see
messages that something is waiting for a user of this module to go away and it
just loops...
Comment 2 Christopher Brown 2008-02-03 18:58:05 EST
(In reply to comment #1)
> Someone posted a fix for this on linux-kernel jan. 9 2008. Not sure if that's
> been included in the rawhide kernel already, but now I don't get an oops any
> more. I still can't suspend though because of some refcounting issues. I see
> messages that something is waiting for a user of this module to go away and it
> just loops...

Try adding:

SUSPEND_MODULES="iwl3945" to /etc/pm/config.d/unload_modules

Also people have had issues if they add vga= parameters to the boot line

Changing subject to reflect the fact that the oops is resolved...
Comment 3 Kjartan Maraas 2008-02-11 05:17:56 EST
Seems to work for me now with the current kernel from rawhide. 

kernel-2.6.24.1-26.fc9.i686

Comment 4 Christopher Brown 2008-02-11 08:03:09 EST
Okay, wireless updates should come through with 2.6.24 kernel for F8. Please
re-open if this is not resolved in that update.

Note You need to log in before you can comment on or make changes to this bug.