Bug 371401 - mail-notification crashes on first startup
mail-notification crashes on first startup
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mail-notification (Show other bugs)
7
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Thorsten Leemhuis
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-08 11:17 EST by Dominik 'Rathann' Mierzejewski
Modified: 2007-12-31 11:35 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-31 11:35:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gdb trace of the crash (11.46 KB, text/plain)
2007-11-08 11:17 EST, Dominik 'Rathann' Mierzejewski
no flags Details

  None (edit)
Description Dominik 'Rathann' Mierzejewski 2007-11-08 11:17:40 EST
Description of problem:
mail-notification crashes on first startup after login. Subsequent startups work
fine.

Version-Release number of selected component (if applicable):
$ rpm -q mail-notification
mail-notification-4.1-1.fc7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. configure mail-notification to be started automatically
2. reboot
3. login

  
Actual results:
mail-notification crashes

Expected results:
It should start without crashing.

Additional info:
gdb trace collected by bug-buddy attached
Comment 1 Dominik 'Rathann' Mierzejewski 2007-11-08 11:17:40 EST
Created attachment 251731 [details]
gdb trace of the crash
Comment 2 Thorsten Leemhuis 2007-11-08 14:25:59 EST
(In reply to comment #0)
[...]
> 1. configure mail-notification to be started automatically
[...]

What do you mean by this? mail-notification starts by default everytime if it's
installed (which might be a bug, but that's another story); maybe you started
two instances in parallel which then lead to the error? 
Comment 3 Dominik 'Rathann' Mierzejewski 2007-11-08 16:32:38 EST
(In reply to comment #2)
> (In reply to comment #0)
> [...]
> > 1. configure mail-notification to be started automatically
> [...]
> 
> What do you mean by this? mail-notification starts by default everytime if
> it's installed (which might be a bug, but that's another story); maybe you
> started two instances in parallel which then lead to the error? 

I wasn't aware. I thought if it's not configured (no mail accounts set), then it
doesn't run. Or something like that. Anyway, no, I'm not running two instances.
Comment 4 Dominik 'Rathann' Mierzejewski 2007-11-08 17:22:07 EST
(In reply to comment #3)
> (In reply to comment #2)
> > (In reply to comment #0)
> > [...]
> > > 1. configure mail-notification to be started automatically
> > [...]
> > 
> > What do you mean by this? mail-notification starts by default everytime if
> > it's installed (which might be a bug, but that's another story); maybe you
> > started two instances in parallel which then lead to the error? 
> 
> I wasn't aware. I thought if it's not configured (no mail accounts set),
> then it doesn't run. Or something like that. Anyway, no, I'm not running
> two instances.

Apparently I lied, sorry. I went back to System->Preferences->Personal->Sessions
and found two Mail Notifications there, one under "No Name". Removing one of
them solves the crash (when it crashed, both of them were dying). But still, it
shouldn't crash. Mind you, this home directory was used all the way back to
FC-3, so it might have accumulated some cruft in gnome settings.
Comment 5 Thorsten Leemhuis 2007-11-25 08:07:09 EST
well, it's a corner case and one that is unlikely to be Fedora specific. I'd
forward this upstream -- but is that worth the trouble?
Comment 6 Thorsten Leemhuis 2007-12-31 11:35:48 EST
Closing this; it looks like a (non-Fedora-specific) corner-case 

Note You need to log in before you can comment on or make changes to this bug.