Bug 37171 - iwconfig segfault with kernel-2.2.19-7.0.1
Summary: iwconfig segfault with kernel-2.2.19-7.0.1
Status: CLOSED DUPLICATE of bug 37083
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: wireless-tools (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-23 08:08 UTC by Marcel Telka
Modified: 2014-03-17 02:20 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-23 08:11:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace iwconfig eth1 (4.15 KB, text/plain)
2001-04-23 08:11 UTC, Marcel Telka
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2001:054 normal SHIPPED_LIVE New wireless-tools package available 2001-04-23 04:00:00 UTC

Description Marcel Telka 2001-04-23 08:08:35 UTC
After upgrade my RHL-7.0 box to kernel-2.2.19-7.0.1 (from kernel-2.2.17-14)
iwconfig generates segfault. I'm using module wvlan_cs which comes with
kernel-2.2.19 and wireless-tools-20-2 (from RHL-7.0).

[root@tortuga /root]# iwconfig eth1
eth1      IEEE 802.11-DS  ESSID:"WaveLAN Network"  Nickname:"HERMES I"
          Frequency:2.457GHz  Sensitivity:1/3  Mode:Managed  
          Access Point: 00:60:1D:F6:7C:39
          Bit Rate:5.5Mb/s   RTS thr:off   Fragment thr:off   
          Encryption key:off
          Power Management:off
          Link quality:15/92  Signal level:-86 dBm  Noise level:-101 dBm
          Rx invalid nwid:0  invalid crypt:0  invalid misc:0

Segmentation fault (core dumped)

Comment 1 Marcel Telka 2001-04-23 08:11:52 UTC
Created attachment 16085 [details]
strace iwconfig eth1

Comment 2 Bill Nottingham 2001-04-23 15:09:33 UTC

*** This bug has been marked as a duplicate of 37083 ***

Comment 3 Bill Nottingham 2001-04-23 18:19:02 UTC
If you download:

http://people.redhat.com/notting/wireless/wireless-tools-21-0.i386.rpm,

does that work for you?

Comment 4 Marcel Telka 2001-04-23 18:37:16 UTC
Yes. `iwconfig eth1` doesn't generate segfault.


Note You need to log in before you can comment on or make changes to this bug.