Bug 371811 - REGRESSION: snmpd problem on EL5 64bit with bonded nics
REGRESSION: snmpd problem on EL5 64bit with bonded nics
Status: CLOSED DUPLICATE of bug 223236
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: net-snmp (Show other bugs)
5.0
All Linux
low Severity low
: ---
: ---
Assigned To: Jan Safranek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-08 15:41 EST by Jeff Schroeder
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-09 03:20:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Schroeder 2007-11-08 15:41:14 EST
Description of problem:
snmpd spams the logs with the following errors on EL5 64bit:
Nov  8 10:28:10 ops3.sys.adm1 snmpd[2454]: error on subcontainer 'ia_addr'
insert (-1)
Nov  8 10:28:10 ops3.sys.adm1 snmpd[2454]: error on subcontainer '' insert (-1)

Version-Release number of selected component (if applicable):
net-snmp-5.3.1-14.0.1.el5

Additional info:
net-snmp upstream says this is a problem with duplicate ip addresses and have a
patch to a) Make the log message more clear that it detected duplicate ip
addresses and b) Only log once instead of something like once every 20 seconds.
Duplicate ip addresses are because of the bonding module.


http://net-snmp.sourceforge.net/wiki/index.php/5.4.1_open_issues
http://sourceforge.net/tracker/index.php?func=detail&aid=1712645&group_id=12694&atid=312694
bug report
http://sourceforge.net/tracker/index.php?func=detail&aid=1693039&group_id=12694&atid=112694
PATCH
Comment 1 Jeff Schroeder 2007-11-08 15:54:15 EST
Downgrading net-snmp to 5.2.1 fixes the problem, but that isn't the desired result.
Comment 2 Jan Safranek 2007-11-09 03:20:16 EST
It is my patch :). Please update to Red Hat Enterprise Linux 5.1
(net-snmp-5.3.1-19, I think).

*** This bug has been marked as a duplicate of 223236 ***

Note You need to log in before you can comment on or make changes to this bug.