Bug 371921 - Yum displays error when Conflicts & Provides name same package
Yum displays error when Conflicts & Provides name same package
Status: CLOSED DUPLICATE of bug 371941
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-08 16:47 EST by Michael McLagan
Modified: 2014-01-21 18:00 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-09 01:43:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 371941 None None None Never

  None (edit)
Description Michael McLagan 2007-11-08 16:47:21 EST
Description of problem:

I'm not entirely sure to whom this may fall, if anyone.  I tripped across
something that seemed to me should have worked but it didn't.  Here's what
I had going on:

Built a spec for sendmail+spf that had the following in it:

   %define base sendmail

   Name: %{base}+spf
   Conflicts: %{base}
   Provides: %{base} = %{version}

I left the rest out, it doesn't seem to matter.  The way I read that is:

   This is a package called sendmail+spf.  If sendmail is installed, this
   package should not be installed because it conflicts (or sendmail should
   be removed if this is installed).  Since other programs  may depend on
   sendmail and this package essentially has sendmail within it, it therefore
   provides plain sendmail of the same version as this package.

Yum called it an error and refused to do anything else with it, as shown below.
If Yum thinks this is an error, then I would think that RPM should flag the 
spec file with an appropriate error message and refuse to build the package.
If RPM happens to agree with my interpretation of what I explained above, then 
Yum should willingly download and possibly install that package.

So, since bugzilla won't let me submit a bug against multiple packages, I'm 
going to submit it twice and link them to each other, leaving the groups to 
figure out which will address this.


Version-Release number of selected component (if applicable):

rpm-build-4.4.2.2-2.fc7
yum-3.2.7-1.fc7

How reproducible:

Always

Steps to Reproduce:
1. Create spec as above
2. Place into a repository
3. Try to retrieve it
  
Actual results:

[root@linux i386]# yum update sendmail+spf

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Updating:
 sendmail+spf            i386       8.14.1-6         local             1.6 M

Transaction Summary
=============================================================================
Install      0 Package(s)         
Update       1 Package(s)         
Remove       0 Package(s)         

Total download size: 1.6 M
ERROR with rpm_check_debug vs depsolve:
Package sendmail+spf conflicts with sendmail.
[root@linux i386]# rpm -qa | grep send
sendmail+spf-devel-8.14.1-5
sendmail+spf-cf-8.14.1-5
sendmail+spf-8.14.1-5

Expected results:

I thought it would go ahead and update it.

Additional info:
Comment 1 James Antill 2007-11-08 17:38:04 EST
 You probably just want to provide MTA smtpd smtpdaemon ... which is what
exim/postifx etc. do. But AIUI provides work the same as having packages named
that way ... so conflicts work against them, thus. this is an rpm bug.

Comment 2 Panu Matilainen 2007-11-09 01:43:11 EST

*** This bug has been marked as a duplicate of 371941 ***

Note You need to log in before you can comment on or make changes to this bug.