Bug 37198 - Directory selection adds /.. instead of shortening path
Summary: Directory selection adds /.. instead of shortening path
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: xmms   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-23 13:59 UTC by Kirk Morrow
Modified: 2014-03-17 02:20 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-03 17:45:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kirk Morrow 2001-04-23 13:59:10 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2 i586)


When selecting a file to play, selecting the /.. directory adds /.. to the
path instead of removing the last directory level.  This only happens when
the return key is used, not when double clicked by the mouse.

Reproducible: Always
Steps to Reproduce:
1. Open the "Load File" window by selecting "Load File" or "+ File" in the
playlist editor.
2. Highlight the /.. selection under "Directories"
3. Use the "Return" key to select instead of double clicking the mouse.
	

Actual Results:  The value /.. is appended to the path.  If building a
playlist by scanning through directories rapidly by using the keyboard and
mouse (as I do when DJing parties) the path name starts getting wider than
the screen.

Expected Results:  The value /.. should have removed the last directory
level from the path and shortened the path name.

Comment 1 Kirk Morrow 2002-01-03 17:45:46 UTC
This bug appears to be fixed in xmms-1.2.6-pre2 pre-release version.  When a
1.2.6 release RPM becomes available I will test it again.

Comment 2 Bill Nottingham 2002-01-15 22:25:02 UTC
will be fixed in 1.2.6-1 because of this; thanks!


Note You need to log in before you can comment on or make changes to this bug.