Bug 372121 - Package "pulseaudio" should require libpulsecore.so.4
Package "pulseaudio" should require libpulsecore.so.4
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-08 22:27 EST by Troels Just
Modified: 2008-09-30 11:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-30 11:29:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
(screenshot #1) pulseaudio-core-libs not installed, pulseaudio daemon non-functional (167.29 KB, image/png)
2007-11-08 22:27 EST, Troels Just
no flags Details
(screenshot #2) Pulseaudio daemon not running because of missing core library, no sound in KDE (594.47 KB, image/png)
2007-11-08 22:31 EST, Troels Just
no flags Details
/var/log/anaconda* (20.24 KB, application/x-tgz)
2007-11-12 12:07 EST, Troels Just
no flags Details

  None (edit)
Description Troels Just 2007-11-08 22:27:26 EST
Description of problem:
The package "pulseaudio" does not have libpulsecore.so.4 from the package 
pulseaudio-core-libs, as a dependency. This is a problem if another package's 
dependencies does not pull it in. 
To me it makes no sense that the package "pulseaudio" does not require 
libpulsecore.so.4, because the binary for the daemon, which is in the 
package "pulseaudio", needs this library to run.

Version-Release number of selected component (if applicable):
Fedora 8

How reproducible:
Easily reproduceable

Steps to Reproduce:
The way I ran into this scenario, was during installation. I deselected all 
the checked categories of default apps in the Applications category of 
Anaconda. The reason being that I am a KDE guy, and I did not particularly 
want half of GNOME installedm when I did not need it (Installing Totem would 
pull in A LOT of GNOME stuff).

Actual results:
When trying to start the Pulseaudio daemon when the package 
pulseaudio-core-libs is not installed, the program exits with this error:
"pulseaudio: error while loading shared libraries: libpulsecore.so.4: cannot 
open shared object file: No such file or directory." (See screenshot #1).

One serious problem that this causes, is that KDE is configured by default to 
use Pulseaudio, and if Pulseaudio's daemon is not running, well no sound for 
KDE (See screenshot #2).

Additional info:
This problem can be solved, by simply adding libpulsecore.so.4 as a dependency 
of the package "pulseaudio".

I have only been able to verify this on i386 (Tested on two machines), but 
since it's the same SRPM used for all the builds, it ought to be a problem on 
x86_64 and PPC as well.
Comment 1 Troels Just 2007-11-08 22:27:26 EST
Created attachment 252351 [details]
(screenshot #1) pulseaudio-core-libs not installed, pulseaudio daemon non-functional
Comment 2 Troels Just 2007-11-08 22:31:05 EST
Created attachment 252361 [details]
(screenshot #2) Pulseaudio daemon not running because of missing core library, no sound in KDE
Comment 3 Troels Just 2007-11-08 22:45:33 EST
UPDATE: Having poked around a little more, I apologize for not trying this 
before submitting this bug report, it would seem like the package pulseaudio 
does indeed have libpulsecore.so.4 as a dependency, but it was not installed 
during the installation, so essentially Anaconda missed a dependency, which is 
why I assumed the dependency was missing.
Comment 4 Lennart Poettering 2007-11-11 11:34:27 EST
Hmm. In fact, the "pulseaudio" package does contains a versioned dependency on
"pulseaudio-core-libs".

If you say this is Anaconda's fault, then this is bug should be reassigned to
Anaconda.

Reassigning.
Comment 5 Chris Lumens 2007-11-12 11:48:14 EST
Please atttach /var/log/anaconda* to this bug report.
Comment 6 Troels Just 2007-11-12 12:07:02 EST
Created attachment 255461 [details]
/var/log/anaconda*
Comment 7 Troels Just 2007-11-12 12:12:08 EST
Comment on attachment 255461 [details]
/var/log/anaconda*

Here they are. Like I mentioned, during the install that produced these logs,
pulseaudio-core-libs was not installed, even when it's a dependency of
"pulseaudio".
Comment 8 Andy Lindeberg 2008-09-30 11:29:49 EDT
This bug should be fixed in rawhide. Please reopen this report if you find that it is still a problem.

Note You need to log in before you can comment on or make changes to this bug.