Bug 372191 - NFS client kernel crashed on nfs-fsstress
NFS client kernel crashed on nfs-fsstress
Status: CLOSED DUPLICATE of bug 466164
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-09 01:13 EST by wmg
Modified: 2008-11-05 01:52 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-05 01:52:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wmg 2007-11-09 01:13:50 EST
Description of problem:
i add test suite from LTP to RHTS 
when i run  it on RHEL server 5.1, the  kernel (2.6.18-53.el5) crashed, and I
got two different kernel  crash messages in two times on the "nfs_fsstress" test:

logger: 2007-11-07 20:41:22 /usr/bin/rhts-test-runner.sh 10882 2880 hearbeat...
BUG: unable to handle kernel NULL pointer dereference at virtual address 000000b8
printing eip:
f8d992de
*pde = 16838001
Oops: 0002 [#1]
SMP
last sysfs file: /devices/pci0000:00/0000:00:03.0/0000:02:1d.0/0000:04:02.0/irq
Modules linked in: nfs lockd fscache nfs_acl autofs4 hidp rfcomm l2cap bluetooth
sunrpc ipv6 dm_mirror dm_multipath dm_mod parport_pc lp parport sg i2c_i801
floppy i2c_core intel_rng e1000 serio_raw pcspkr e7xxx_edac edac_mc ata_piix
libata qla2xxx scsi_transport_fc sd_mod scsi_mod ext3 jbd ehci_hcd ohci_hcd uhci_hcd
CPU:    3
EIP:    0060:[<f8d992de>]    Not tainted VLI
EFLAGS: 00010246   (2.6.18-53.el5PAE #1)
EIP is at nfs_direct_write_complete+0x37/0x237 [nfs]
eax: 00000001   ebx: 00000000   ecx: 00000001   edx: dda2d900
esi: dd696580   edi: 00000004   ebp: d63e15f0   esp: f7014f40
ds: 007b   es: 007b   ss: 0068
Process rpciod/3 (pid: 5534, ti=f7014000 task=f7f89550 task.ti=f7014000)
Stack: dda2d900 f8d9b5b0 dd696580 00000000 00000202 f8b8d822 dd696584 dd6965ec
      f8b8e033 dd6965f4 dd6965f8 f6a88e40 c04336fc f8b8e03d dd696584 f6a88e54
      f6a88e40 f6a88e4c 00000000 c0433fb0 00000001 00000000 f7f8965c 00010000
Call Trace:
[<f8b8d822>] rpc_release_calldata+0x16/0x20 [sunrpc]
[<f8b8e033>] __rpc_execute+0x1ee/0x1f8 [sunrpc]
[<c04336fc>] run_workqueue+0x78/0xb5
[<f8b8e03d>] rpc_async_schedule+0x0/0x5 [sunrpc]
[<c0433fb0>] worker_thread+0xd9/0x10d
[<c04206f9>] default_wake_function+0x0/0xc
[<c0433ed7>] worker_thread+0x0/0x10d
[<c0436385>] kthread+0xc0/0xeb
[<c04362c5>] kthread+0x0/0xeb
[<c0405c3b>] kernel_thread_helper+0x7/0x10
=======================
Code: 8b 45 3c c7 45 3c 00 00 00 00 83 f8 01 74 0e 83 f8 02 0f 85 bc 01 00 00 e9
e0 00 00 00 8b 5d 38 b9 01 00 00 00 8b 55 0c 8d 7b 04 <89> 93 b8 00 00 00 8b 45
04 81 ea 2c 01 00 00 8b 40 0c 89 93 70
EIP: [<f8d992de>] nfs_direct_write_complete+0x37/0x237 [nfs] SS:ESP 0068:f7014f40
<0>Kernel panic - not syncing: Fatal exception



logger: 2007-11-07 21:28:01 /usr/bin/rhts-test-runner.sh 10857 840 hearbeat...
nfs: server nec-em12.rhts.boston.redhat.com not responding, timed out
nfs: server nec-em12.rhts.boston.redhat.com not responding, timed out
------------[ cut here ]------------
kernel BUG at fs/nfs/proc.c:677!
invalid opcode: 0000 [#1]
SMP
last sysfs file: /devices/pci0000:00/0000:00:00.0/irq
Modules linked in: nfs lockd fscache nfs_acl autofs4 hidp rfcomm l2cap bluetooth
sunrpc ipv6 dm_mirror dm_multipath dm_mod parport_pc lp parport sg i2c_i801
i2c_core e7xxx_edac edac_mc floppy e1000 intel_rng serio_raw pcspkr ata_piix
libata qla2xxx scsi_transport_fc sd_mod scsi_mod ext3 jbd ehci_hcd ohci_hcd uhci_hcd
CPU:    3
EIP:    0060:[<f8d7f339>]    Not tainted VLI
EFLAGS: 00010246   (2.6.18-53.el5PAE #1)
EIP is at nfs_proc_commit_setup+0x0/0x9 [nfs]
eax: f0b23c80   ebx: f0b23c80   ecx: f8d96700   edx: 00000000
esi: f2633780   edi: f0b23c84   ebp: eec7f6d4   esp: f1034f34
ds: 007b   es: 007b   ss: 0068
Process rpciod/3 (pid: 5403, ti=f1034000 task=f2743aa0 task.ti=f1034000)
Stack: f8d9537c f8d975bc f0b23c80 ebc3c168 f8d975b0 f2633780 00000000 00000202
      f8b9d822 f2633784 f26337ec f8b9e033 f26337f4 f26337f8 f227cc40 c04336fc
      f8b9e03d f2633784 f227cc54 f227cc40 f227cc4c 00000000 c0433fb0 00000001
Call Trace:
[<f8d9537c>] nfs_direct_write_complete+0xd5/0x237 [nfs]
[<f8b9d822>] rpc_release_calldata+0x16/0x20 [sunrpc]
[<f8b9e033>] __rpc_execute+0x1ee/0x1f8 [sunrpc]
[<c04336fc>] run_workqueue+0x78/0xb5
[<f8b9e03d>] rpc_async_schedule+0x0/0x5 [sunrpc]
[<c0433fb0>] worker_thread+0xd9/0x10d
[<c04206f9>] default_wake_function+0x0/0xc
[<c0433ed7>] worker_thread+0x0/0x10d
[<c0436385>] kthread+0xc0/0xeb
[<c04362c5>] kthread+0x0/0xeb
[<c0405c3b>] kernel_thread_helper+0x7/0x10
=======================
Code: 89 46 24 8b 44 24 04 e8 44 be ff ff 89 46 10 5f 89 d8 5d 5b 5e 5f 5d c3 90
90 31 c0 c7 41 04 00 00 00 00 c7 41 08 ff 00 00 00 c3 <0f> 0b a5 02 b3 90 d9 f8
c3 8b 40 08 8b 40 0c e9 2d 28 df ff 83
EIP: [<f8d7f339>] nfs_proc_commit_setup+0x0/0x9 [nfs] SS:ESP 0068:f1034f34
<0>Kernel panic - not syncing: Fatal exception





Version-Release number of selected component (if applicable):


How reproducible:

run the rhts with name /kernel/distribution/nfs/ltp
or you can refer to rhts jobid:  10364

Additional info:

seems it just happens on the nfs client can't get responding from the nfs server
Comment 1 CAI Qian 2008-11-05 01:52:50 EST
It looks like a very similar back trace with bug 466164. Hence, I close this one as the duplication of it. You may re-open it if disagree.

*** This bug has been marked as a duplicate of bug 466164 ***

Note You need to log in before you can comment on or make changes to this bug.