Bug 372211 - Can't open MS 2007 ooxml docx files
Can't open MS 2007 ooxml docx files
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
: 432124 432125 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-09 02:20 EST by Adam Bentitou
Modified: 2008-02-19 09:38 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-19 09:38:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Bentitou 2007-11-09 02:20:01 EST
The OpenOffice 2.3 included in Fedora 8 cannot open MS 2007 ooxml documents.
The easy workaround that existed in OO2.2 no longer works for 2.3.

This functionality is not in the upstream but, Ubuntu 7.10 seems to have
managed to get this feature to work in their OO2.3 package, so it shouldn't
be too bad to implement their fix.
The Ubuntu 7.10 oo2.3 diff can be found here:
http://spout.ussg.indiana.edu/linux/ubuntu/pool/main/o/openoffice.org/openoffice.org_2.3.0-1ubuntu5.1.diff.gz


Yes, they seem to have just one huge diff for the whole open office project, ugly!
Comment 1 Caolan McNamara 2007-11-09 04:34:37 EST
F8 is finished, post release is too late to request features.
Comment 2 Luis Villa 2008-02-07 10:14:40 EST
Mumble. Just had a professor send me one of these. :/
Comment 3 Caolan McNamara 2008-02-13 04:17:49 EST
*** Bug 432124 has been marked as a duplicate of this bug. ***
Comment 4 Caolan McNamara 2008-02-13 04:18:48 EST
*** Bug 432125 has been marked as a duplicate of this bug. ***
Comment 5 Caolan McNamara 2008-02-19 09:38:44 EST
wrt #1 of course Ubuntu doesn't actually implement anything themselves wrt. OOo
they're backporting from what'll be OOo 3.0 work done by Sun and Novell.

I'm going to hold off for 3.0 on this one, frustrating as it might be in the
interim. Its just too raw for now.

Note You need to log in before you can comment on or make changes to this bug.