Bug 372641 - no sound with snd-hda-intel
no sound with snd-hda-intel
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i386 Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-09 07:05 EST by Klaus Möllenhoff
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.6.23.1-49.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-20 09:07:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of errormessage when clicking on speaker icon (239.12 KB, image/png)
2007-11-09 07:05 EST, Klaus Möllenhoff
no flags Details
/root/scsconfig.log (39.97 KB, text/plain)
2007-11-15 06:28 EST, Klaus Möllenhoff
no flags Details
dmesg when booting with live cd (20.76 KB, application/octet-stream)
2007-11-15 10:58 EST, Klaus Möllenhoff
no flags Details

  None (edit)
Description Klaus Möllenhoff 2007-11-09 07:05:59 EST
Description of problem: no audio output available


Version-Release number of selected component (if applicable): 


How reproducible: allways


Steps to Reproduce:
1. boot
2.
3.
  
Actual results: 


Expected results:


Additional info:

first boot after yum upgrade to f8 everything worked fine. now there is now
sound output. 

in /var/log/messages:

Nov 9 10:27:05 klaus kernel: snd_hda_codec: Unknown symbol snd_ctl_elem_read
Nov 9 10:27:05 klaus kernel: snd_hda_codec: Unknown symbol snd_ctl_elem_write
Nov 9 10:27:05 klaus kernel: snd_hda_intel: Unknown symbol snd_hda_bus_new
Nov 9 10:27:05 klaus kernel: snd_hda_intel: Unknown symbol snd_hda_build_pcms
Nov 9 10:27:05 klaus kernel: snd_hda_intel: Unknown symbol snd_hda_codec_new
Nov 9 10:27:05 klaus kernel: snd_hda_intel: Unknown symbol snd_hda_queue_unsol_event
Nov 9 10:27:05 klaus kernel: snd_hda_intel: Unknown symbol
snd_hda_calc_stream_format
Nov 9 10:27:05 klaus kernel: snd_hda_intel: Unknown symbol snd_hda_suspend
Nov 9 10:27:05 klaus kernel: snd_hda_intel: Unknown symbol
snd_hda_codec_remove_notify_all
Nov 9 10:27:05 klaus kernel: snd_hda_intel: Unknown symbol snd_hda_resume
Nov 9 10:27:05 klaus kernel: snd_hda_intel: Unknown symbol snd_hda_build_controls
Nov 9 10:27:05 klaus kernel: usbcore: registered new interface driver snd-usb-audio
Nov 9 10:27:05 klaus kernel: snd_hda_codec: Unknown symbol snd_ctl_elem_read
Nov 9 10:27:05 klaus kernel: snd_hda_codec: Unknown symbol snd_ctl_elem_write
Nov 9 10:27:05 klaus kernel: snd_hda_intel: Unknown symbol snd_hda_bus_new
Nov 9 10:27:05 klaus kernel: snd_hda_intel: Unknown symbol snd_hda_build_pcms
Nov 9 10:27:05 klaus kernel: snd_hda_intel: Unknown symbol snd_hda_codec_new
Nov 9 10:27:05 klaus kernel: snd_hda_intel: Unknown symbol snd_hda_queue_unsol_event
Nov 9 10:27:05 klaus kernel: snd_hda_intel: Unknown symbol
snd_hda_calc_stream_format
Nov 9 10:27:05 klaus kernel: snd_hda_intel: Unknown symbol snd_hda_suspend
Nov 9 10:27:05 klaus kernel: snd_hda_intel: Unknown symbol
snd_hda_codec_remove_notify_all
Nov 9 10:27:05 klaus kernel: snd_hda_intel: Unknown symbol snd_hda_resume
Nov 9 10:27:05 klaus kernel: snd_hda_intel: Unknown symbol snd_hda_build_controls


and:

Nov 9 10:35:45 klaus pulseaudio[2963]: protocol-esound.c:
pulsecore/protocol-esound.c: Failed to create sink input.
...
Nov 9 11:21:43 klaus pulseaudio[2963]: protocol-esound.c:
pulsecore/protocol-esound.c: Failed to create sink input.

if i click on the speaker in the upper right corner i get an error message like:

there are now gstreaemer-plugins (see screenshot (sorry, but its in german)



dont know if its really belongs to pulseaudio. but in f7 everything worked fine.
even dont know if its a new bug, but i did not find anything
Comment 1 Klaus Möllenhoff 2007-11-09 07:05:59 EST
Created attachment 252671 [details]
screenshot of errormessage when clicking on speaker icon
Comment 2 Lennart Poettering 2007-11-11 11:27:32 EST
This looks like an ALSA kernel issue. Reassigning.
Comment 3 Klaus Möllenhoff 2007-11-12 08:10:16 EST
with new kernel 2.6.23.1-49.fc8 everything works fine
Comment 4 Klaus Möllenhoff 2007-11-12 17:58:32 EST
sorry, but sound worked only at first boot after kernel update! 
now its not working again...

what is the difference from first boot after kernel update and later boots?
Comment 5 Klaus Möllenhoff 2007-11-14 09:28:36 EST
no idea why it isnt working? perhaps it is an alsa problem?
Comment 6 Klaus Möllenhoff 2007-11-15 06:28:47 EST
Created attachment 259731 [details]
/root/scsconfig.log
Comment 7 Klaus Möllenhoff 2007-11-15 06:30:50 EST
i attached the /root/scsconfig.log which was generated by system-config-soundcard.

i tested /etc/modprobe.conf with 
alias snd-card-0 snd-hda-intel model=dell-laptop
but its still not working! no idea why this isnt working, or why it worked after
first boot with new kernel?
Comment 8 Klaus Möllenhoff 2007-11-15 10:58:16 EST
Created attachment 259941 [details]
dmesg when booting with live cd

with live cd everything works... like after installing new kernel.

here is the dmesg output when booting with live cd
Comment 9 Klaus Möllenhoff 2007-11-18 06:09:24 EST
hello?? is there anybody?

do someone know what else i can do to solve this bug?
Comment 10 Klaus Möllenhoff 2007-11-18 13:41:37 EST
i installed the fedora 7 kernel-2.6.23.1-21.fc7.i686.rpm with

rpm -i --force kernel-2.6.23.1-21.fc7.i686.rpm  

and everything seems to work with the fedora7 kernel. i rebooted twice and it
still works!

what changed from f7 to f8 in the sound driver section?
Comment 11 Klaus Möllenhoff 2007-11-20 08:13:04 EST
is a maintainer reading this???

no idea why this happens?

i dont have an idea how to find out what changed from fedora 7 to fedora 8
kernel... if you tell me how i find this out i will do it
Comment 12 Klaus Möllenhoff 2007-11-20 09:07:36 EST
solved the problem myself.

it wasnt a kernel bug. seems that conexant modem driver from www.linuxant.com
does not work with fedora8. i removed it before between update to .49er kernel
and installing fedora 7 kernel. because of this the module was not build at
startup for the fedora 7 kernel, but it was still there for the new kernel.

i removed the new kernel and removed everything in /lib/modules/2.6.23.1-49.fc8
and made a yum update. now everything works!

Note You need to log in before you can comment on or make changes to this bug.