Bug 372851 - system-config-selinux needs a package of its own
system-config-selinux needs a package of its own
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: policycoreutils (Show other bugs)
5.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-09 10:15 EST by Lutz Lange
Modified: 2008-09-10 12:04 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-09 14:51:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lutz Lange 2007-11-09 10:15:28 EST
Description of problem:
system-config-selinux breaks the chain. Other system-config-tools are packages
on their own. Because of this system-config-selinux is kind of hard to find.

Version-Release number of selected component (if applicable):


How reproducible:
if you dont know that what the tool is actually called it is easy to miss and
hard to find the right package.

Steps to Reproduce:
1. yum list system-config*
2.
3.
  
Actual results:


Expected results:
system-config-selinux.i386 or something

Additional info:
Please put selinux in a package by its name.
Comment 1 Daniel Walsh 2008-09-09 14:51:29 EDT
Not all system-config-* apps there own rpm matching the name.

authconfig
serviceconfig
Comment 2 Lutz Lange 2008-09-09 16:06:12 EDT
(In reply to comment #1)
> Not all system-config-* apps there own rpm matching the name.
> 
> authconfig
> serviceconfig

But you'll have to agree, that there is some wisdom in using system-config-* as a package name. I think pointing to other exceptions is not a strong argument. 

Where or who could make a general decision to putting all system-config tools in packages by their names?
Comment 3 Daniel Walsh 2008-09-10 12:04:17 EDT
That's fine but bring it up for discussion on the fedora-devel list.

system-config-selinux is really the gui for policycoreutils, hense it is in policycoreutils-gui package.

You can install a package by executing

yum install /usr/bin/system-config-selinux

And it will find the correct package.

Note You need to log in before you can comment on or make changes to this bug.