Bug 373211 - smolt should only be runnable by root
smolt should only be runnable by root
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: smolt (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Mike McGrath
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-09 12:29 EST by Need Real Name
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-23 12:56:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2007-11-09 12:29:15 EST
The admin of a machine should have control over who submits hardware information
about it to a central source.

smolt's send profile app should only be runnable by root.
Comment 1 Ricky Zhou 2007-11-23 11:09:53 EST
What's to stop somebody from getting/sending completely unprivileged hardware
information to a smolt server anyway?  Having smolt fail for non-root should not
make this information any less available to somebody that wants to submit it.
Comment 2 Mike McGrath 2007-11-23 12:56:06 EST
The admin of a machine can do this after install if they wish, but to allow 
only root is an illusion as people could just download the smolt source and 
send it that way.
Comment 3 Need Real Name 2007-11-23 13:31:36 EST
The difference is about of information disclosed and ease of use. Smolt makes it
easy to reveal a lot of information about a box very quickly.
Comment 4 Mike McGrath 2007-11-23 13:56:50 EST
Still an illusion, lshal shows way more information about a box (things like 
service tag even)
Comment 5 Need Real Name 2007-11-23 14:09:47 EST
lshal doesn't submit to a centralised database.

Your "illusion" is broken. My issue is that smolt makes it simple for a person
who does not own a box to submit information to a centralised place.

The fact that they can download smolt, remove the suggested check for uid 0,
then run it, proves my point - you've made it harder for them, which is the the
point.
Comment 6 Mike McGrath 2007-11-23 14:31:04 EST
The illusion I'm referring to is admins thinking that if smolt is root-only 
runable that their profile won't end up in the database, because that's just 
not the case.  

Meanwhile I find it bad to run applications as root and never do it unless 
required.  

Note You need to log in before you can comment on or make changes to this bug.