This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 37331 - user pref file name corruption
user pref file name corruption
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: xchat (Show other bugs)
1.0
All Linux
high Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
: 38312 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-24 05:18 EDT by Tothwolf
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-16 16:46:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
updated japanese patch for 1.6.4 (94.66 KB, application/octet-stream)
2001-04-24 05:22 EDT, Tothwolf
no flags Details
updated jp2 patch for 1.6.4 (1.44 KB, patch)
2001-04-24 05:23 EDT, Tothwolf
no flags Details | Diff
jp3 patch to fix filename corruption bug (1.27 KB, patch)
2001-04-24 05:24 EDT, Tothwolf
no flags Details | Diff
spec file patch (1.45 KB, patch)
2001-04-24 05:25 EDT, Tothwolf
no flags Details | Diff

  None (edit)
Description Tothwolf 2001-04-24 05:18:44 EDT
Starting xchat from gnome menu causes user pref files buttons.conf,
popup.conf, and usermenu.conf in $HOME/.xchat to be named 'buttons.(n.conf'
etc. This is caused by a bug in xchat_lingul_conf_suffix() which was added
to src/common/xchat.c by xchat-1.6.3-japanese.patch. This bug could also
cause xchat to crash under some situations. usermenu.conf is also missing a
filename conversion in src/fe-gtk/menu.c.
Comment 1 Tothwolf 2001-04-24 05:22:07 EDT
Created attachment 16185 [details]
updated japanese patch for 1.6.4
Comment 2 Tothwolf 2001-04-24 05:23:17 EDT
Created attachment 16186 [details]
updated jp2 patch for 1.6.4
Comment 3 Tothwolf 2001-04-24 05:24:30 EDT
Created attachment 16187 [details]
jp3 patch to fix filename corruption bug
Comment 4 Tothwolf 2001-04-24 05:25:24 EDT
Created attachment 16188 [details]
spec file patch
Comment 5 Tothwolf 2001-04-25 05:16:35 EDT
jp3 patch has bad logic, it will need to be replaced by a proper patch.
Comment 6 Havoc Pennington 2001-07-16 16:46:00 EDT
*** Bug 38312 has been marked as a duplicate of this bug. ***
Comment 7 Havoc Pennington 2001-07-16 16:51:51 EDT
I believe this should be fixed in Rawhide with xchat 1.8.x upgrade - 
please reopen the bug if you rediscover it. Things worked well when I tested it
though.

Note You need to log in before you can comment on or make changes to this bug.