Bug 373541 - Use locking_type = 0 for LVM queries in fence_scsi, scsi_reserve
Use locking_type = 0 for LVM queries in fence_scsi, scsi_reserve
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cman (Show other bugs)
5.0
All Linux
low Severity low
: ---
: ---
Assigned To: Ryan O'Hara
Cluster QE
:
: 447465 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-09 14:34 EST by Ryan O'Hara
Modified: 2010-10-22 16:11 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2008-0347
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:58:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ryan O'Hara 2007-11-09 14:34:31 EST
Need to use "locking_type = 0" for lvm queries in both fence_scsi and
scsi_reserve scripts. This will override locking_type such that we can retrieve
list of devices in clvm volumes at fence time. Also results it ability to remove
state file, whcih currently keeps track of devices that node is known to be
registered with. This greatly simplifies the SCSI reservation scrips and solves
problem with startup fencing.
Comment 2 RHEL Product and Program Management 2008-01-07 15:45:13 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 3 Ryan O'Hara 2008-01-18 18:20:28 EST
Fixed. This not only allows us to query clvmd for cluster volumes (and the
devices that makeup those volumes) at fence time, but also removes the need to
keep a state file on each and every node in the cluster. Previously, we had to
keep a state file which recorded all devices the node had registered with so
that we could determine which devices to unregister with at fence time. There
were many problems/limitations associated with this state file technique.

Instead, the scripts now use the "--config 'global {locking_type = 0}'" option
with all lvm commands. This fix required change to all three scripts related to
SCSI reservations: scsi_reserve, fence_scsi, and fence_scsi_test.

Comment 6 Ryan O'Hara 2008-05-20 12:11:05 EDT
*** Bug 447465 has been marked as a duplicate of this bug. ***
Comment 7 errata-xmlrpc 2008-05-21 11:58:23 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0347.html

Note You need to log in before you can comment on or make changes to this bug.