Bug 373801 - Missing requirement: python-zope-interface
Missing requirement: python-zope-interface
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pitivi (Show other bugs)
8
noarch Linux
low Severity medium
: ---
: ---
Assigned To: Jeffrey C. Ollie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-09 16:14 EST by Robert-André Mauchin
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 0.11.0-2.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-20 12:48:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert-André Mauchin 2007-11-09 16:14:12 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en; rv:1.8.1.8) Gecko/20071030 Epiphany/2.20 Firefox/2.0.0.8

Description of problem:
Pitivi seems to be mispackaged : python can't found zope.interface module, because 
 python-zope-interface is not set as an install dependancy.

Version-Release number of selected component (if applicable):
pitivi-0.11.0-1.fc8

How reproducible:
Always


Steps to Reproduce:
1.Install pitivi
2.Launch pitivi
3.

Actual Results:
Traceback (most recent call last):
  File "/usr/bin/pitivi", line 113, in <module>
    _run_pitivi()
  File "/usr/bin/pitivi", line 102, in _run_pitivi
    import pitivi.pitivi as pitivi
  File "/usr/share/pitivi/python/pitivi/pitivi.py", line 29, in <module>
    from ui import mainwindow
  File "/usr/share/pitivi/python/pitivi/ui/mainwindow.py", line 49, in <module>
    from pluginmanagerdialog import PluginManagerDialog
  File "/usr/share/pitivi/python/pitivi/ui/pluginmanagerdialog.py", line 29, in <module>
    import pitivi.plugincore as plugincore
  File "/usr/share/pitivi/python/pitivi/plugincore.py", line 22, in <module>
    from zope.interface import Interface, Attribute
ImportError: No module named zope.interface


Expected Results:


Additional info:
Comment 1 Fedora Update System 2007-11-12 19:11:34 EST
pitivi-0.11.0-2.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update pitivi'
Comment 2 Robert-André Mauchin 2007-11-12 19:31:45 EST
Thanks, works correctly now.
Comment 3 Fedora Update System 2007-11-20 12:48:56 EST
pitivi-0.11.0-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.