Bug 373881 - Clean install F8 running kde gives pulseaudio crash
Clean install F8 running kde gives pulseaudio crash
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
8
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-09 16:51 EST by Mike Cohler
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-27 13:05:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backtrace from kde crash handler (2.26 KB, text/plain)
2007-11-09 16:51 EST, Mike Cohler
no flags Details

  None (edit)
Description Mike Cohler 2007-11-09 16:51:05 EST
Description of problem:


Version-Release number of selected component (if applicable):
pulseaudio-0.9.7-0.17.svn20071017.fc8


How reproducible:Every time


Steps to Reproduce:
1. Boot up and login to KDE
2. If KDE sound is running get multiple kde crash handler windows.
3. Need to stop KDE sound altogether to stop getting crash handler popups
  
Actual results:Get stream of kde crash handler pop-up windows


Expected results:Sound in kde should work normally and no crash handler appear


Additional info:backtrace will be attached to this bz shortly.
Comment 1 Mike Cohler 2007-11-09 16:51:54 EST
Created attachment 253621 [details]
backtrace from kde crash handler
Comment 2 Mike Cohler 2007-11-10 17:16:49 EST
I also noted that in the /var/log/messages file there is a line:
Nov  9 17:41:21 lapmike2 pulseaudio[2914]: main.c: This program is not intended
to be run as root (unless --system is specified).


Could this be related to 
https://bugzilla.redhat.com/show_bug.cgi?id=366401

?
Comment 3 Lennart Poettering 2007-11-11 11:48:04 EST
Are you doing this as root? You shouldn't log in graphically as root.
Comment 4 Mike Cohler 2007-11-11 16:27:48 EST
No - this is a normal user login to kde.
Comment 5 Mike Cohler 2007-11-12 14:18:13 EST
I don't know if this is relevant or not but the install was clean with no users
added during install. The users were connected back from the /home area in a
separate untouched partition that was working fine in F7 prior to installing F8.
i.e. the passwd, group, shadow and gshadow files had the user lines added from
the  corresponding files that had been saved from the F7 setup. This was once
this was done all previous user areas were usable just as before the change to
F8.  However is it possible that a config file somewhere that was pre-existing
in F7, and the new install would have created it differently could cause these
symptoms?  If so how can I find if there is such a config file that is not set
correctly?

eg is there are files in ~/.kde/share/config or similar that might be different
if it had been created in f8 with default settings?
Comment 6 Mike Cohler 2007-11-13 12:34:30 EST
I get sound just fine with Amarok, and also going to the web in Firefox gives
sound with flash video and real video (after installing the appropriate plugins)

So it is only kde sound that is affected this way for me. 
Comment 7 Mike Cohler 2007-11-14 05:01:24 EST
I have found a resolution to this problem. It seems that no file called
/etc/asound.conf or ~/.asoundrc was created during the f8 install.

If I simply create a file /etc/asound.conf containing the lines:
pcm.pulse {
    type pulse
}

ctl.pulse {
    type pulse
}

as per the instructions at http://www.pulseaudio.org/wiki/PerfectSetup

and make no other changes then kde sound works normally with pulseaudio.

This therefore resolves this bug which can now be closed.
Comment 8 Mike Cohler 2007-11-27 13:03:44 EST
I have now removed the pulse-audio package according to posts in Fedora List and
have had no further problems.
Closing this bug.

Note You need to log in before you can comment on or make changes to this bug.