Bug 37431 - pacct accton init script chkconfig
pacct accton init script chkconfig
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: psacct (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-24 10:22 EDT by Mike Sklar
Modified: 2008-05-01 11:38 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-12 18:32:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Sklar 2001-04-24 10:22:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-2 i686)


process accounting should have chkconfig manageability

Reproducible: Always
Steps to Reproduce:
1. Boot your machine
2. Process accounting is now running (if installed)
3. There only way to turn it off is to run "accton" manually. Which is in
itself unintuitive.
	

Actual Results:  Process accounting is no longer running, but on next boot
it will be on again.

Expected Results:  Process accounting should be managed through a init
script. Some machines generate such a load that the log files from process
accounting become large and unweidly.

accton is already in the halt script, but it needs to be configured as its
own start/stop init script
Comment 1 Daniel Roesen 2001-04-24 15:33:55 EDT
Strongly ACKed
Comment 2 Chris Rode 2001-04-25 18:55:42 EDT
Hate to post a "me too", but please please please, yes!  This should be a 
fairly simple and straightforward change to make, neh? :)
Comment 3 Mike A. Harris 2001-05-02 15:24:27 EDT
Looking into a solution for next release.
Comment 4 Enrico Scholz 2001-12-12 18:32:08 EST
Still in 7.2.

I installed psacct on my laptop to have its documentation available there. Now
psacct is starting at every boot unconditionally[1], accesses the harddisk
frequently and prevents it to go into suspend mode.


[1] because of 
     ---- /etc/rc.sysinit ---
    | # Turn on process accounting
    | if [ -x /sbin/accton ] ; then
    |    action $"Turning on process accounting" /sbin/accton /var/log/pacct
    | fi
Comment 5 Mike A. Harris 2002-03-12 07:25:30 EST
Ok, I have finally put a bullet in this giant hard-disk-filling,
laptop-non-suspending annoyance.

psacct 6.3.2-15 in rawhide now has a standalone initscript.  You'll
need initscripts 6.55 as well which I've removed the accton calls from.

Note You need to log in before you can comment on or make changes to this bug.