Bug 374351 - Beagle doesn't even start
Beagle doesn't even start
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: beagle (Show other bugs)
8
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Alexander Larsson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-10 01:46 EST by Renich Bon Ciric
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-11 14:41:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Renich Bon Ciric 2007-11-10 01:46:06 EST
Description of problem:
Beagle issues this error when attempting to start and fails:
[renich@introdesk ~]$ beagled
The assembly mscorlib.dll was not found or could not be loaded.
It should have been installed in the `/usr/lib/mono/2.0/mscorlib.dll' directory.
Beagle Daemon exited with errors.  See ~/.beagle/Log/current-Beagle for more
details.


Version-Release number of selected component (if applicable):
0.2.18-1

How reproducible:
[renich@introdesk ~] yum upgrade -y

[renich@introdesk ~] yum install beagle.x86_64

[renich@introdesk ~] beagled

Steps to Reproduce:
1. Fully upgrade the system
2. Install beagle: yum install beagle.x86_64
3. Try to start beagle: beagled
  
Actual results:
[renich@introdesk ~]$ beagled
The assembly mscorlib.dll was not found or could not be loaded.
It should have been installed in the `/usr/lib/mono/2.0/mscorlib.dll' directory.
Beagle Daemon exited with errors.  See ~/.beagle/Log/current-Beagle for more
details.


Expected results:
<beagle starting without a problem

Additional info:
According to the issued error, it might be a problem in mono
Comment 1 Matthias Clasen 2007-11-10 23:36:27 EST
Looks like a multilib issue to me.
It works fine on my i386 installation.
mscorlib.dll is in the mono-core package.
Do you have that installed ? And if yes, what arches ?
Comment 2 Renich Bon Ciric 2007-11-11 02:26:30 EST
mono-core.x86_64                         1.2.5.1-2.fc8          installed 
Comment 3 Renich Bon Ciric 2007-11-11 03:20:43 EST
Well, today, just after the post, there was a mono-core update available. You
were right; this solved the issues regarding beagle and tomboy, which didn't
work either.

What should I do with this bug? Pointed somewhere else? Reference it? Just set
it as "Resolved" or something?
Comment 4 Matthias Clasen 2007-11-11 14:41:39 EST
ok, closing then.

Note You need to log in before you can comment on or make changes to this bug.