Bug 374361 - Gstreamer fails to load some plugins
Gstreamer fails to load some plugins
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gstreamer-plugins (Show other bugs)
8
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-10 01:58 EST by Renich Bon Ciric
Modified: 2013-03-13 00:51 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-01 10:36:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Renich Bon Ciric 2007-11-10 01:58:45 EST
Description of problem:
Gstreamer issues a warning about being unable to load some plugins.

Version-Release number of selected component (if applicable):
gstreamer-plugins-base-0.10.14-6.fc8
gstreamer-plugins-bad-extras-0.10.5-10.lvn8
gstreamer-ffmpeg-0.10.2-4.lvn8
gstreamer-0.10.14-4.fc8
gstreamer-plugins-ugly-0.10.6-2.lvn8
gstreamer-plugins-base-0.10.14-6.fc8
gstreamer-0.10.14-4.fc8
gstreamer-plugins-good-0.10.6-6.fc8
gstreamer-plugins-bad-0.10.5-10.lvn8
gstreamer-plugins-schroedinger-0.6.1-3.fc8
gstreamer-tools-0.10.14-4.fc8
gstreamer-plugins-farsight-0.12.5-1.fc8
gstreamer-plugins-pulse-0.9.5-0.4.svn20070924.fc8


How reproducible:
1. upgrade your f8 distro up to the top: yum upgrade -y
2. try using gstreamer in any way, for example, gstreamer-properties <-- type
that on CLI


Steps to Reproduce:
1. yum upgrade -y
2. gstreamer-properties 
  
Actual results:
[renich@introdesk ~]$ gstreamer-properties 

(gstreamer-properties:12166): GStreamer-WARNING **: Failed to load plugin
'/usr/lib64/gstreamer-0.10/libgstfaac.so': libmp4v2.so.0: cannot open shared
object file: No such file or directory

(gstreamer-properties:12166): GStreamer-WARNING **: Failed to load plugin
'/usr/lib64/gstreamer-0.10/libgstffmpeg.so': libmp4v2.so.0: cannot open shared
object file: No such file or directory

(gstreamer-properties:12166): GStreamer-WARNING **: Failed to load plugin
'/usr/lib64/gstreamer-0.10/libgstpostproc.so': libmp4v2.so.0: cannot open shared
object file: No such file or directory
gstreamer-properties-Message: Skipping unavailable plugin 'artsdsink'
gstreamer-properties-Message: Skipping unavailable plugin 'esdsink'
gstreamer-properties-Message: Skipping unavailable plugin 'v4lmjpegsrc'
gstreamer-properties-Message: Skipping unavailable plugin 'qcamsrc'
gstreamer-properties-Message: Skipping unavailable plugin 'esdmon'
Comment 1 Renich Bon Ciric 2007-11-11 18:05:41 EST
I used, after adding the livna repo

[renich@introdesk ~]$ su -c 'smart update && smart fix'

and it installed flaac and some other 2 packages... one was python package and
the other one was ov... something. Sorry, I forgot to write it down... sorry ;=s

Anyway, if you can reproduce it, you'll get the list of missing rpm packages
that yum failed to install/resolve or maybe anaconda, since it was a vanilla
installation.
Comment 2 Bastien Nocera 2008-09-01 10:36:46 EDT
We don't support smart in Fedora, and in all cases, this a problem with livna's repo not having correct deps. You shouldn't have been able to install those packages if deps are missing...

Note You need to log in before you can comment on or make changes to this bug.