Bug 374581 - system-config-display crashed with python traceback
system-config-display crashed with python traceback
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-display (Show other bugs)
8
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
: 413611 414421 441760 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-10 08:14 EST by Gian Mario Tagliaretti
Modified: 2008-04-11 15:09 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-11 15:09:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gian Mario Tagliaretti 2007-11-10 08:14:45 EST
Description of problem:
system-config-display crashes

Version-Release number of selected component (if applicable):
fresh install of a fedora core 8

How reproducible:
always
  
Actual results:

running from console

[gianmt@localhost ~]$ /usr/bin/system-config-display -v
Read configuration file /etc/X11/xorg.conf
Trying with card: ATI Technologies Inc M56P [Radeon Mobility X1600]
Traceback (most recent call last):
  File "/usr/share/system-config-display/xconf.py", line 381, in <module>
    dialog = xConfigDialog.XConfigDialog(hardware_state, xconfig,
rhpxl.videocard.VideoCardInfo())
  File "/usr/share/system-config-display/xConfigDialog.py", line 533, in __init__
    self.state.recalc_mode()
  File "/usr/lib/python2.5/site-packages/rhpxl/xhwstate.py", line 387, in
recalc_mode
    self.colordepth = availableDepth[-1]
IndexError: list index out of range

I can provide more info if needed.
Comment 1 Florian Sievert 2007-11-11 05:36:39 EST
I can confirm this problem on my system. Somebody on the german fedora forum
also mentioned, that he engaged the problem, so it might be common.

Konfigurationsdatei /etc/X11/xorg.conf lesen
Versuche mit Karte: ATI Technologies Inc Radeon Mobility X1400
Traceback (most recent call last):
  File "/usr/share/system-config-display/xconf.py", line 381, in <module>
    dialog = xConfigDialog.XConfigDialog(hardware_state, xconfig,
rhpxl.videocard.VideoCardInfo())
  File "/usr/share/system-config-display/xConfigDialog.py", line 533, in __init__
    self.state.recalc_mode()
  File "/usr/lib/python2.5/site-packages/rhpxl/xhwstate.py", line 387, in
recalc_mode
    self.colordepth = availableDepth[-1]
IndexError: list index out of range
Comment 2 Pawel Salek 2007-11-14 15:06:27 EST
I see this as well when I run this tool while having an external LCD projector
connected to my laptop. The native resolution of the laptop is 1440x900, the LCD
projected displays only 1024x768. For what is worth, gnome-display-properties
tool display in such a situation an empty list of resolutions which does not
seem like an entirely expected behavior either.
Comment 3 J.Jansen 2008-01-07 06:13:45 EST
Same error on a x86-64 system
  Hardware : HP8710W laptop with Nvidia chipset configured as Twinview (CRT+LCD)

csardas-jj ) system-config-display 
Traceback (most recent call last):
  File "/usr/share/system-config-display/xconf.py", line 381, in <module>
    dialog = xConfigDialog.XConfigDialog(hardware_state, xconfig,
rhpxl.videocard.VideoCardInfo())
  File "/usr/share/system-config-display/xConfigDialog.py", line 533, in __init__
    self.state.recalc_mode()
  File "/usr/lib64/python2.5/site-packages/rhpxl/xhwstate.py", line 387, in
recalc_mode
    self.colordepth = availableDepth[-1]
IndexError: list index out of range
Comment 4 Adam Jackson 2008-04-11 15:02:17 EDT
*** Bug 441760 has been marked as a duplicate of this bug. ***
Comment 5 Adam Jackson 2008-04-11 15:04:05 EDT
*** Bug 413611 has been marked as a duplicate of this bug. ***
Comment 6 Adam Jackson 2008-04-11 15:06:09 EDT
*** Bug 414421 has been marked as a duplicate of this bug. ***
Comment 7 Adam Jackson 2008-04-11 15:09:43 EDT
Fixed in git.  (Actually a rhpxl bug, not an s-c-d bug, but let's not split hairs.)

Note You need to log in before you can comment on or make changes to this bug.