Bug 374781 - Perl in 86_64 does not have the correct libraries for buliding XS modules.
Summary: Perl in 86_64 does not have the correct libraries for buliding XS modules.
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: perl   
(Show other bugs)
Version: 8
Hardware: x86_64
OS: Linux
low
urgent
Target Milestone: ---
Assignee: Robin Norwood
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-11-10 16:00 UTC by Kaleb Murphy
Modified: 2007-11-30 22:12 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-10 22:59:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kaleb Murphy 2007-11-10 16:00:17 UTC
Description of problem:
In Fedora 8 86_64 it does not appear that the Perl RPM includes the correct
libraries in the correct locations for cpan to build Perl packages that include
XS modules.  I've tried manually building these packages with the same errors.

Version-Release number of selected component (if applicable):
Perl v5.8.8 built for x86_64-linux-thread-multi


How reproducible:
Very.

Steps to Reproduce:
1. as root
2. cpan -i HTML::Strip (or any Perl package that requires XS to build)
3.
  
Actual results:
[root@jet ~]# cpan -i HTML::Strip
CPAN: Storable loaded ok (v2.15)
Going to read /root/.cpan/Metadata
  Database was generated on Fri, 09 Nov 2007 19:36:36 GMT
Running install for module 'HTML::Strip'
Running make for K/KI/KILINRAX/HTML-Strip-1.06.tar.gz

  CPAN: checksum security checks disabled because Digest::SHA not installed.
  Please consider installing the Digest::SHA module.

CPAN: Time::HiRes loaded ok (v1.86)
CPAN: Compress::Zlib loaded ok (v2.005)
HTML-Strip-1.06/Changes
HTML-Strip-1.06/Makefile.PL
HTML-Strip-1.06/MANIFEST
HTML-Strip-1.06/README
HTML-Strip-1.06/Strip.pm
HTML-Strip-1.06/Strip.xs
HTML-Strip-1.06/strip_html.h
HTML-Strip-1.06/strip_html.c
HTML-Strip-1.06/typemap
HTML-Strip-1.06/test.pl
CPAN: File::Temp loaded ok (v0.16)

  CPAN.pm: Going to build K/KI/KILINRAX/HTML-Strip-1.06.tar.gz

Checking if your kit is complete...
Looks good
Writing Makefile for HTML::Strip
cp Strip.pm blib/lib/HTML/Strip.pm
/usr/bin/perl /usr/lib/perl5/vendor_perl/5.8.8/ExtUtils/xsubpp  -typemap
/usr/lib/perl5/5.8.8/ExtUtils/typemap -typemap typemap  Strip.xs > Strip.xsc &&
mv Strip.xsc Strip.c
gcc -c   -D_REENTRANT -D_GNU_SOURCE -fno-strict-aliasing -pipe
-Wdeclaration-after-statement -I/usr/local/include -D_LARGEFILE_SOURCE
-D_FILE_OFFSET_BITS=64 -I/usr/include/gdbm -O2 -g -pipe -Wall
-Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4
-m64 -mtune=generic   -DVERSION=\"1.06\" -DXS_VERSION=\"1.06\" -fPIC
"-I/usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi/CORE"   Strip.c
In file included from Strip.xs:3:
/usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi/CORE/perl.h:420:24: error:
sys/types.h: No such file or directory
/usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi/CORE/perl.h:451:19: error:
ctype.h: No such file or directory
/usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi/CORE/perl.h:463:23: error:
locale.h: No such file or directory
/usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi/CORE/perl.h:480:20: error:
setjmp.h: No such file or directory
/usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi/CORE/perl.h:486:26: error:
sys/param.h: No such file or directory
/usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi/CORE/perl.h:491:23: error:
stdlib.h: No such file or directory
/usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi/CORE/perl.h:496:23: error:
unistd.h: No such file or directory
/usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi/CORE/perl.h:776:23: error:
string.h: No such file or directory
/usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi/CORE/perl.h:925:27: error:
netinet/in.h: No such file or directory
/usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi/CORE/perl.h:929:26: error:
arpa/inet.h: No such file or directory
/usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi/CORE/perl.h:939:25: error:
sys/stat.h: No such file or directory
/usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi/CORE/perl.h:961:21: error:
time.h: No such file or directory
/usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi/CORE/perl.h:968:25: error:
sys/time.h: No such file or directory
/usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi/CORE/perl.h:975:27: error:
sys/times.h: No such file or directory
/usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi/CORE/perl.h:982:19: error:
errno.h: No such file or directory
/usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi/CORE/perl.h:997:25: error:
sys/socket.h: No such file or directory
/usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi/CORE/perl.h:1024:21: error:
netdb.h: No such file or directory
/usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi/CORE/perl.h:1127:24: error:
sys/ioctl.h: No such file or directory
/usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi/CORE/perl.h:1156:23: error:
dirent.h: No such file or directory

......Followed by a ton of errors about missing headers in .c files.

Expected results:
HTML::Strip installed okay.

Additional info:
This is with Perl-Devel (86 & 64) and Perl-libs installed.

Comment 1 Kaleb Murphy 2007-11-10 16:48:04 UTC
It looks like perl.h is looking for header files which do not exist anywhere in
the /usr/lib64/perl5 directory.

Comment 2 Tom "spot" Callaway 2007-11-10 19:47:40 UTC
Do you have perl-devel and glibc-headers installed?

Comment 3 Kaleb Murphy 2007-11-10 22:59:44 UTC
I just installed glibc-headers which required kernel-headers and that resolved
the problem.  When I configured my installed packages, was there a dev group I
should have selected?  I guess what I'm asking is what should I have selected to
make sure that perl-devel, cpan, and glibc-headers were installed?

Thanks for the help and I'll change the status to not a bug, although I think it
is strange to package Perl without the ability to install new packages from CPAN
and instead rely upon packages being available in the repos.


Note You need to log in before you can comment on or make changes to this bug.