Bug 37484 - xdvi passes wrong /tmp directory to mktexpk
xdvi passes wrong /tmp directory to mktexpk
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: tetex (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-24 18:39 EDT by Ed Friedman
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-02 16:58:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ed Friedman 2001-04-24 18:39:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.2.17-14 i686)


 xdvi dmj010424
kpathsea: Running mktexpk --mfmode ljfour --bdpi 600 --mag 1+0/600 --dpi
600 
cmr9
mkdir: cannot create directory `/mt25541.tmp': Permission denied
kpathsea: Appending font creation commands to missfont.log.
xdvi.bin: Can't find font cmr9.600pk
kpathsea: Running mktexpk --mfmode ljfour --bdpi 600 --mag 1+120/600 --dpi
720 
msbm10
mkdir: cannot create directory `/mt25550.tmp': Permission denied


Reproducible: Always
Steps to Reproduce:
1.Create .tex file with any of the above listed fonts
2.Create .dvi file from the above .tex file
3. Run xdvi on the .dvi file and observe these errors
	

Actual Results:   xdvi dmj010424
kpathsea: Running mktexpk --mfmode ljfour --bdpi 600 --mag 1+0/600 --dpi
600 
cmr9
mkdir: cannot create directory `/mt25541.tmp': Permission denied
kpathsea: Appending font creation commands to missfont.log.
xdvi.bin: Can't find font cmr9.600pk
kpathsea: Running mktexpk --mfmode ljfour --bdpi 600 --mag 1+120/600 --dpi
720 
msbm10
mkdir: cannot create directory `/mt25550.tmp': Permission denied


Expected Results:  no error messages

From the error message, it appears that / is being listed as the temporary
directory instead of /tmp
Comment 1 Sammy 2001-04-26 10:47:59 EDT
Well I have the same packages and it is working fine! It just created some new fonts
in /tmp this morning. Just to try something get the -16 rpms from rawhide and try
them out.
Comment 2 Tim Waugh 2001-05-02 16:58:03 EDT
Perhaps you have something odd in your environment which is setting / as the 
temporary directory?

Could you attach a small example tex file that shows this up, so that we know 
we're trying the same thing?
Comment 3 Ed Friedman 2001-05-15 12:38:05 EDT
The problem was caused by the user's path causing a version of MakeTeXPK to be
seen before the 7.1 version.  This should no longer be considered a bug.

Note You need to log in before you can comment on or make changes to this bug.