Bug 37491 - Install with USB mouse creates unusable config on Sony PCG-F480
Install with USB mouse creates unusable config on Sony PCG-F480
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-24 22:06 EDT by Greg Corson
Modified: 2007-04-18 12:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-30 12:10:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Greg Corson 2001-04-24 22:06:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)


Did a "everything" install on a Sony PCG-F480, specified a USB Microsoft 
Intelemouse.  Install completed normally with no apparent errors.  On 
reboot the USB mouse did not work, system was running very slowly, XF86 
config file did not contain entries for USB.

Reproducible: Always
Steps to Reproduce:
1.Do an everything install
2.When prompted for mouse, choose Microsoft Intelimouse USB
3.
	

Actual Results:  System comes up in a very broken state, running about 10x 
slower than it should despite TOP only reporting about 10 percent load.  
USB does not work.  /proc/bus/usb not created, none of the USB scanning 
tools work.

Expected Results:  Should have come up without problems

Don't know if this is the laptop's fault or yours, have never tried USB on 
it under Linux before.

You need a configuration for laptops that supports an internal trackpad 
AND a hot-pluggable USB mouse at the same time.
Comment 1 Brent Fox 2001-04-24 22:26:54 EDT
On our internal laptop testing (with IBM Thinkpads, Dell Inspirons, and Compaq
Presarios), USB works just fine...during install and after reboot.  There may be
some hardware difference with the Sonys that makes things not work.  If things
work during the install, but not after, I'm inclinced to think that the problem
may lie somewhere else...like the kernel.  After you boot the installed system,
can you do 'lsmod' and see if the USB drivers are even getting loaded?
Comment 2 Greg Corson 2001-04-26 12:49:30 EDT
During the install, the USB mouse was never active.  I presumed this to be 
because you had to substitute a new kernel before USB would come up.

I have since re-installed the system with normal mouse and it seems to be 
working, but doesn't appear to have USB enabled.  No /proc/bus/usb filesystem 
was mounted and no kernel messages show up when you hot-plug a USB device.

The best way to find out what's wrong might be to walk me through adding a usb 
device to working system 7.1 system I have right now.  So far I haven't been 
able to get any USB stuff to work at all, the KDE system manager seems to 
recognize the usb hub is there, but nothing else does.
Comment 3 Brent Fox 2001-04-26 14:27:35 EDT
Hmm, this is starting to sound like either a kudzu or a kernel problem,
especially since you see the problem after installation.  Are you sure that USB
is enabled in your bios?

Bill, any ideas on this?
Comment 4 Greg Corson 2001-04-26 14:49:28 EDT
I should have mentioned before...windows reports the USB device as

Intel 82371AB/EB PCI to USB Universal Host Controller

I've been testing with a standard Intelimouse USB with wheel.  I also have a 
USB "natural" keyboard, but haven't bothered trying that yet.
Comment 5 Bill Nottingham 2001-04-26 15:16:46 EDT
lspci -v output?

What does 'modprobe usb-uhci' say?
Comment 6 Greg Corson 2001-04-26 18:27:05 EDT
00:00.0 Host bridge: Intel Corporation 440BX/ZX - 82443BX/ZX Host bridge (rev 
03)
        Subsystem: Sony Corporation: Unknown device 806f
        Flags: bus master, medium devsel, latency 64
        Memory at 40000000 (32-bit, prefetchable) [size=16M]
        Capabilities: [a0] AGP version 1.0

00:01.0 PCI bridge: Intel Corporation 440BX/ZX - 82443BX/ZX AGP bridge (rev 
03) (prog-if 00 [Normal decode])
        Flags: bus master, 66Mhz, medium devsel, latency 128
        Bus: primary=00, secondary=01, subordinate=01, sec-latency=64
        Memory behind bridge: fe800000-fecfffff
        Prefetchable memory behind bridge: fd000000-fdffffff

00:07.0 ISA bridge: Intel Corporation 82371AB PIIX4 ISA (rev 02)
        Flags: bus master, medium devsel, latency 0

00:07.1 IDE interface: Intel Corporation 82371AB PIIX4 IDE (rev 01) (prog-if 
80 [Master])
        Flags: bus master, medium devsel, latency 64
        I/O ports at fcf0 [size=16]

00:07.2 USB Controller: Intel Corporation 82371AB PIIX4 USB (rev 01) (prog-if 
00 [UHCI])
        Flags: medium devsel
        I/O ports at fcc0 [disabled] [size=32]

00:07.3 Bridge: Intel Corporation 82371AB PIIX4 ACPI (rev 03)
        Flags: medium devsel, IRQ 9

00:08.0 FireWire (IEEE 1394): Sony Corporation CXD3222 i.LINK Controller (rev 
02) (prog-if 10 [OHCI])
        Subsystem: Sony Corporation: Unknown device 8071
        Flags: medium devsel
        Memory at fedff000 (32-bit, non-prefetchable) [disabled] [size=2K]
        Memory at fedffc00 (32-bit, non-prefetchable) [disabled] [size=512]
        Expansion ROM at <unassigned> [disabled] [size=64K]
        Capabilities: [dc] Power Management version 1

00:09.0 Multimedia audio controller: Yamaha Corporation YMF-744B [DS-1S Audio 
Controller] (rev 02)
        Subsystem: Sony Corporation: Unknown device 8072
        Flags: bus master, medium devsel, latency 64, IRQ 9
        Memory at fedf0000 (32-bit, non-prefetchable) [size=32K]
        I/O ports at fc40 [size=64]
        I/O ports at fcec [size=4]
        Capabilities: [50] Power Management version 1
 
00:0a.0 Class 0708: Rockwell International HCF 56k V90 FaxModem (rev 01)
        Subsystem: Sony Corporation: Unknown device 8074
        Flags: medium devsel, IRQ 9
        Memory at fede0000 (32-bit, non-prefetchable) [disabled] [size=64K]
        I/O ports at fce0 [disabled] [size=8]
        Capabilities: [40] Power Management version 2
 
00:0c.0 CardBus bridge: Ricoh Co Ltd RL5c478 (rev 80)
        Subsystem: Sony Corporation: Unknown device 8073
        Flags: bus master, medium devsel, latency 168, IRQ 9
        Memory at 10000000 (32-bit, non-prefetchable) [size=4K]
        Bus: primary=00, secondary=02, subordinate=02, sec-latency=176
        Memory window 0: 10400000-107ff000 (prefetchable)
        Memory window 1: 10800000-10bff000
        I/O window 0: 00001400-000014ff
        I/O window 1: 00001800-000018ff
        16-bit legacy interface ports at 0001
 
00:0c.1 CardBus bridge: Ricoh Co Ltd RL5c478 (rev 80)
        Subsystem: Sony Corporation: Unknown device 8073
        Flags: bus master, medium devsel, latency 168, IRQ 9
        Memory at 10001000 (32-bit, non-prefetchable) [size=4K]
        Bus: primary=00, secondary=06, subordinate=06, sec-latency=176
        Memory window 0: 10c00000-10fff000 (prefetchable)
        Memory window 1: 11000000-113ff000
        I/O window 0: 00001c00-00001cff
        I/O window 1: 00002000-000020ff
        16-bit legacy interface ports at 0001
 
01:00.0 VGA compatible controller: Neomagic Corporation [MagicMedia 256AV] 
(rev 20) (prog-if 00 [VGA])
        Subsystem: Sony Corporation: Unknown device 8070
        Flags: bus master, fast Back2Back, medium devsel, latency 128, IRQ 9
        Memory at fd000000 (32-bit, prefetchable) [size=16M]
        Memory at fe800000 (32-bit, non-prefetchable) [size=4M]
        Memory at fec00000 (32-bit, non-prefetchable) [size=1M]
        Capabilities: [dc] Power Management version 1

The modprobe command generates no output....

By the way, just to clarify...when I say this was an "everything" install I 
mean I did a custom install and checked ALL the package boxes.

At the moment I'm running an everything install where a normal PS2 mouse was 
specified, but usb-wise it appears to have the same configuration as the 
install I did with a USB mouse setting (for example /proc/bus/usb was missing 
on both installs).

Also, don't know if this is relavent, but we've noticed that "workstation" 
installs seem to do a few things different from the "everything" install, for 
example the KDE font setup seems different, and NIS seems to have different 
settings for NIS+ vs NIS support.  Not directly related of course, but seems 
to point to a noticablly different install setup.

Comment 7 Bill Nottingham 2001-04-26 21:14:51 EDT
It looks like your USB controller is disabled in the BIOS.
Comment 8 Brent Fox 2001-04-27 11:03:49 EDT
If the kernel saw your USB controller, you would see an entry from lspci that
looks like (from my workstation):

00:1f.2 USB Controller: Intel Corporation 82801AA USB (rev 02) (prog-if 00 [UHCI])
        Subsystem: Intel Corporation 82801AA USB
        Flags: bus master, medium devsel, latency 0, IRQ 11
        I/O ports at ff80 [size=32]

But the kernel doesn't see the controller anywhere out there on the PCI bus.
Can you make sure the USB controller is enabled?
Comment 9 Greg Corson 2001-04-27 12:00:59 EDT
I don't believe this laptop actually has accessable BIOS settings...there 
doesn't seem to be an option to hit DEL or whatever during boot to see them.  
I'll check for some hidden access to the BIOS, but if the USB port was disabled 
in the bios it wouldn't work in windows, right?  It does work just fine under 
windows 2k (this laptop is a dual-boot to Windows 2k)

The USB controller was listed in the output I sent you, did you miss it?

00:07.2 USB Controller: Intel Corporation 82371AB PIIX4 USB (rev 01) (prog-if 
00 [UHCI])
        Flags: medium devsel
        I/O ports at fcc0 [disabled] [size=32]
Comment 10 Bill Nottingham 2001-04-27 12:22:25 EDT
Yes, but it doesn't have an interrupt assigned to it, which makes
it pretty much unusable under Linux. You'll also note that it lists
the I/O ports as [disabled].
Comment 11 Greg Corson 2001-04-27 18:22:06 EDT
It turns out there are BIOS settings available on this laptop, but they aren't 
very complete.  I just looked through them and there is nothing on any of the 
setup pages related to USB.

The only thing I could see that might be relavent might be the "Plug and Play 
OS" setting which is currently set to YES.  Not sure if changing this would 
help, or have any bad effects on the windows side of my Dual Boot.
Comment 12 Bill Nottingham 2001-04-27 18:39:44 EDT
Please, try turning it off.
Comment 13 Greg Corson 2001-04-27 19:16:10 EDT
Kudzu noticed the USB controller, configured it.  lspci now says:

00:07.2 USB Controller: Intel Corporation 82371AB PIIX4 USB (rev 01) (prog-if 
00 [UHCI])
        Flags: bus master, medium devsel, latency 64, IRQ 9
        I/O ports at fca0 [size=32]

and modprobe says

Note: /etc/modules.conf is more recent than /lib/modules/2.4.2-2/modules.dep  

/var/log/messages says (I disconnected and reconnected the mouse once below)

Apr 27 16:01:08 Gcorson-Win2k kernel: usb.c: registered new driver usbdevfs
Apr 27 16:01:08 Gcorson-Win2k kernel: usb.c: registered new driver hub
Apr 27 16:01:08 Gcorson-Win2k kernel: usb-uhci.c: $Revision: 1.251 $ time 
20:53:29 Apr  8 2001
Apr 27 16:01:08 Gcorson-Win2k kernel: usb-uhci.c: High bandwidth mode enabled
Apr 27 16:01:08 Gcorson-Win2k kernel: PCI: Found IRQ 9 for device 00:07.2
Apr 27 16:01:08 Gcorson-Win2k kernel: PCI: The same IRQ used for device 00:08.0
Apr 27 16:01:08 Gcorson-Win2k kernel: usb-uhci.c: USB UHCI at I/O 0xfca0, IRQ 9
Apr 27 16:01:08 Gcorson-Win2k kernel: usb-uhci.c: Detected 2 ports
Apr 27 16:01:08 Gcorson-Win2k kernel: usb.c: new USB bus registered, assigned 
bus number 1
Apr 27 16:01:08 Gcorson-Win2k kernel: hub.c: USB hub found
Apr 27 16:01:08 Gcorson-Win2k kernel: hub.c: 2 ports detected
Apr 27 16:01:09 Gcorson-Win2k /etc/hotplug/usb.agent: ... no drivers for USB 
product 0/0/0
Apr 27 16:01:09 Gcorson-Win2k kernel: hub.c: USB new device connect on bus1/2, 
assigned device number 2
Apr 27 16:01:09 Gcorson-Win2k kernel: usb.c: USB device 2 (vend/prod 
0x45e/0x9) is not claimed by any active driver.
Apr 27 16:01:09 Gcorson-Win2k kernel: usb.c: registered new driver hid
Apr 27 16:01:09 Gcorson-Win2k kernel: usb-uhci.c: interrupt, status 3, frame# 
1078
Apr 27 16:01:09 Gcorson-Win2k kernel: input0: USB HID v1.00 Mouse [045e:0009] 
on usb1:2.0
Apr 27 16:01:09 Gcorson-Win2k kernel: mouse0: PS/2 mouse device for input0
Apr 27 16:01:09 Gcorson-Win2k kernel: mice: PS/2 mouse device common for all 
mice
Apr 27 16:09:59 Gcorson-Win2k kernel: usb.c: USB disconnect on device 2
Apr 27 16:10:04 Gcorson-Win2k kernel: hub.c: USB new device connect on bus1/1, 
assigned device number 3
Apr 27 16:10:04 Gcorson-Win2k kernel: usb-uhci.c: interrupt, status 3, frame# 
913
Apr 27 16:10:04 Gcorson-Win2k kernel: mouse0: PS/2 mouse device for input0
Apr 27 16:10:04 Gcorson-Win2k kernel: input0: USB HID v1.00 Mouse [045e:0009] 
on usb1:3.0

There is a /proc/bus/usb directory now, but there is nothing in it.

If I cat /dev/input/mice I get characters when I move the USB mouse, but not 
when I move the existing trackpad.

I'm going to try modifying the X setup now, but not sure if I'm doing it 
correctly to allow the trackpad and USB mouse to function simultaniously.  If 
you have a canned setup that allows this (basically, patching in the USB mouse 
whenever it's plugged in) please send it on.

Comment 14 Greg Corson 2001-04-27 19:45:01 EDT
Ok, finished testing and have everything working....after a reboot, the USB 
stuff started to appear in the kernel startup messages (kudzu even caught the 
existance of the new mouse, but I didn't let it config anything)

It has created the /proc/bus/usb filesystem

usbview now works and shows all my devices

I modified the XF86config file as shown on 
http://linuxusbguide.sourceforge.net/USB-guide-1.0.9/x201.html using the 
method for the "wheel mouse" and adding the "send core events" line as shown 
on this page for doing dual mouse.  Things now seem to work ok, hot 
un/plugging the USB mouse works and the trackpad stays on.

The hidden bios problem (accessed by F2 on the Sony laptops) was the primary 
problem...though if the RedHat install script doesn't do the dual mouse stuff 
I mention above, you might want to include it for laptop users.

The only remaining problem is that there doesn't seem to be a way to configure 
the settings for each mouse individually, but this is a minor issue.

Thanks for your help

Note You need to log in before you can comment on or make changes to this bug.