Bug 374991 - bcm43xx kernel module for Broadcom wireless card fails to load
bcm43xx kernel module for Broadcom wireless card fails to load
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
i386 Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-10 14:11 EST by Michael J. Kofler
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-27 18:02:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael J. Kofler 2007-11-10 14:11:14 EST
Description of problem:
modprobe fails for find bcm43xx module for Broadcom wireless card. I have 
copied the correct driver from Windows (BCMWL5.SYS), ran
 bcm43xx-fwcutter -w /lib/firmware BCMWL5.SYS
which extracted the files seemingly without problem.
I then run modprobe bcm43xx and get the error:
[root@tatooine Desktop]# modprobe bcm43xx
FATAL: Module bcm43xx not found.

Running locate seems to indicate that the module is there (see partial output 
below), but it won't load.:

/lib/firmware/bcm43xx_initval01.fw
/lib/firmware/bcm43xx_initval02.fw
/lib/firmware/bcm43xx_initval03.fw
/lib/firmware/bcm43xx_initval04.fw
/lib/firmware/bcm43xx_initval05.fw
/lib/firmware/bcm43xx_initval06.fw
/lib/firmware/bcm43xx_initval07.fw
/lib/firmware/bcm43xx_initval08.fw
/lib/firmware/bcm43xx_initval09.fw
/lib/firmware/bcm43xx_initval10.fw
/lib/firmware/bcm43xx_microcode11.fw
/lib/firmware/bcm43xx_microcode2.fw
/lib/firmware/bcm43xx_microcode4.fw
/lib/firmware/bcm43xx_microcode5.fw
/lib/firmware/bcm43xx_pcm4.fw
/lib/firmware/bcm43xx_pcm5.fw
/lib/modules/2.6.21-1.3194.fc7/kernel/drivers/net/wireless/bcm43xx
/lib/modules/2.6.21-1.3194.fc7/kernel/drivers/net/wireless/bcm43xx/bcm43xx.ko
/lib/modules/2.6.21-1.3194.fc7/kernel/drivers/net/wireless/mac80211/bcm43xx
/lib/modules/2.6.21-1.3194.fc7/kernel/drivers/net/wireless/mac80211/bcm43xx/bcm43xx-mac80211.ko
/usr/bin/bcm43xx-fwcutter


Version-Release number of selected component (if applicable):
kernel-2.6.23.1-21.fc7
kernel-headers-2.6.23.1-21.fc7
kernel-devel-2.6.23.1-21.fc7
bcm43xx-fwcutter-006-1.fc7
Fresh install of FC7 with all updates as of 11-09-07

How reproducible:
Always

Steps to Reproduce:
1.extract bcm files to /lib/firmware with fwcutter as directed in how-to
2.type 'modprobe bcm43xx' to attempt to load module
3.
  
Actual results:
Module fails to load

Expected results:
Module loads

Additional info:
Comment 1 Michael J. Kofler 2007-11-10 18:31:22 EST
The problem was that the bcm43xx modules weren't in the /lib/modules/... for  
kernel-2.6.23.1-21.fc7. I rebooted into kernel 2.6.21... and everything worked 
as expected.

I had updated from kernel 2.6.21 to 2.6.23 - the available modules didn't 
update with it, I guess.
Comment 2 Chuck Ebbert 2007-11-27 18:02:13 EST
The module name has changed to either b43 or b43legacy depending on which exact
model you may have.

Note You need to log in before you can comment on or make changes to this bug.