Bug 375081 - "Import Saved Configuration" does nothing (Create (open)VPN Connection step 2)
"Import Saved Configuration" does nothing (Create (open)VPN Connection step 2)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: NetworkManager-openvpn (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Christoph Höger
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-10 16:58 EST by Stephen Warren
Modified: 2008-05-19 06:56 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-19 05:36:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Warren 2007-11-10 16:58:37 EST
Description of problem:
Attempt to create an OpenVPN configuration. Attempt to import an OpenVPN
configuration file. The request is ignored, with no error/warning message.

Version-Release number of selected component (if applicable):
NetworkManager-0.7.0-0.5.svn3030.fc8
NetworkManager-openvpn-0.7.0-2.svn3047.fc8
NetworkManager-glib-0.7.0-0.5.svn3030.fc8
NetworkManager-gnome-0.7.0-0.5.svn3030.fc8
NetworkManager-vpnc-0.7.0-0.4.svn3030.fc8

How reproducible:
Always

Steps to Reproduce:
1. In Gnome, click nm-applet tray icon
2. Select "VPN Connections" then "Configure VPN"
3. Click "Add"
4. Click "Forward"
5. Select "OpenVPN Client" and click "Forward"
6. Click "Import Saved Configuration"
7. Select an OpenVPN config file, and click "Open"
8. File selector closes, returns to "Create VPN Connection2 of 2"
  
Actual results:
No connection information filled into wizard. No warning/error message displayed.

Expected results:
Wizard text boxes should be filled in from the OpenVPN configuration file and/or
a connection should be created that manages the specified OpenVPN config file
and/or some form of warning/error message should be displayed saying why the
file could not be processed.
Comment 1 Tim Niemueller 2008-01-19 05:23:25 EST
You should note that the import feature will import ini-style files, not
original OpenVPN configuration files! So you create the connection manually once
and then export the file to reuse on other systems.

Currently I do not have the time to write an import for OpenVPN config files by
myself. But patches for this are really welcome.

For a quick fix I will add a warning if the appropriate section in the ini file
is not found so that users know that importing the OpenVPN config is not
supported. I will leave this bug open until this is done.
Comment 2 Stephen Warren 2008-01-19 15:33:25 EST
Rather than NM inventing a new config format for each of the supported VPN
systems, which in turn won't end up supporting all the options that the VPN
clients support, it seems far better if NM simply record the filename of an
existing config file in the format required by the underlying VPN system.

That way, there's no need for "import" at all - the NM config is just the
pre-existing filename. This saves a lot of hassle implementing NM, plus adds
more features (i.e. anything the VPN system supports, not just the minimal info
that NM has in the config GUI).

The only argument against the above is how to initially create the VPN config
file if you don't want to RTFM and use a text editor. I feel that the VPN system
itself should provide the GUI for editing the config file in this case,
either/both as a separate application, or perhaps as a widget to plug into NM or
other GUI apps.
Comment 3 Tim Niemueller 2008-01-19 18:22:19 EST
The NM applet stores the configuration in GConf and has to transmit it over
dbus, so just using the config file is not an option here - by design. After all
we do not want users to have to deal with any kind of config files. The import
feature is meant to make lives easier for administrators for provisioning VPN
access.

The ini-style format was used for two reasons:
1. It was copied from the vpnc plugin and was already available
2. For ini files there is support in the toolkit right away while supporting the
OpenVPN format would have needed quite some work for correct parsing.
Comment 4 Stephen Warren 2008-01-19 21:19:11 EST
Well, there's no need to parse the OpenVPN file format. All NM should be aware
of is the filename, and run openvpn as:

openvpn --config the_stored_filename

Simple!

Without this, the NM OpenVPN support will be completely useless for anybody
who's already using OpenVPN and has configuration files they want to use, so no
point implementing OpenVPN support in NM!
Comment 5 Christoph Höger 2008-05-19 05:36:37 EDT
closed - this is not a bug and should be discussed upstream
Comment 6 Stephen Warren 2008-05-19 06:56:02 EDT
Fedora is upstream for this application, isn't it?

Note You need to log in before you can comment on or make changes to this bug.