Bug 375441 - gdm blows chunks if haldaemon isn't running
gdm blows chunks if haldaemon isn't running
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-10 23:20 EST by Valdis Kletnieks
Modified: 2008-03-07 18:22 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-07 18:22:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Valdis Kletnieks 2007-11-10 23:20:48 EST
Description of problem:
gdm dies with signal 11 if haldaemon isn't running


Version-Release number of selected component (if applicable):
gdm-2.21.2-0.2007.11.09.1.fc9

How reproducible:
'chkconfig haldaemon off', 'service haldaemon stop', and then telinit 3, 5.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Nov 10 22:55:27 turing-police gdm-binary[13565]: WARNING: Unable to query HAL:
The name org.freedesktop.Hal was not provided by any .service file
s
Nov 10 22:55:27 turing-police gdm-binary[13565]: WARNING: Caught signal 11. 
Generating backtrace...
Nov 10 22:55:27 turing-police gdm-binary[13565]: ******************* START
********************************
Nov 10 22:55:27 turing-police gdm-binary[13565]: Frame 0: /usr/sbin/gdm-binary
[0x4134db]
Nov 10 22:55:27 turing-police gdm-binary[13565]: Frame 1: /usr/sbin/gdm-binary
[0x4136b3]
Nov 10 22:55:27 turing-police gdm-binary[13565]: Frame 2: /lib64/libc.so.6
[0x3101630f30]
Nov 10 22:55:27 turing-police gdm-binary[13565]: Frame 3: /usr/sbin/gdm-binary
[0x407b6c]
Nov 10 22:55:27 turing-police gdm-binary[13565]: Frame 4: /usr/sbin/gdm-binary
[0x407465]
Nov 10 22:55:27 turing-police gdm-binary[13565]: Frame 5: /usr/sbin/gdm-binary
[0x40bbdd]
Nov 10 22:55:27 turing-police gdm-binary[13565]: Frame 6: /usr/sbin/gdm-binary
[0x405f94]
Nov 10 22:55:27 turing-police gdm-binary[13565]: Frame 7:
/lib64/libc.so.6(__libc_start_main+0xf4) [0x310161e074]
Nov 10 22:55:27 turing-police gdm-binary[13565]: Frame 8: /usr/sbin/gdm-binary
[0x405469]
Nov 10 22:55:27 turing-police gdm-binary[13565]: ******************* END
**********************************

We get that 5 times, and then 'X respawning too fast, disabling for 5 minutes'.

Expected results:
It's been possible to get an X session started without HAL's help at least since
it was still called X10.4 back in 1986 or so.  It should *still* be possible to
at least get a *GDM* window open without HAL (I'm willing to live with
HAL-related Gnome support not being there once I get in, but jeez, at least
provide a login window and *basic* functionality even without HAL).

Additional info:
Comment 1 Matthias Clasen 2007-11-11 00:28:24 EST
I agree that it shouldn't segfault. 
Comment 2 jmccann 2008-03-07 18:22:43 EST
We no longer use HAL since we don't have real seat support yet anyway.  Should
work in rawhide.  Please reopen if it doesn't.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.