Bug 375501 - Fedora 8 ipw3945 error [NEEDINFO]
Fedora 8 ipw3945 error
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
i386 Linux
low Severity low
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-11-11 00:32 EST by Harry Krevis
Modified: 2009-01-09 00:08 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-01-09 00:08:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
dcbw: needinfo? (harrykrevis)

Attachments (Terms of Use)
error message (705.31 KB, image/png)
2007-11-11 00:32 EST, Harry Krevis
no flags Details

  None (edit)
Description Harry Krevis 2007-11-11 00:32:12 EST
Fedora 8 when activating wlan0 ipw3945 through Network Configurator.

Error for wireless request "Set Mode" (8B06) :
    SET failed on device wlan0 ; Invalid argument.

Determining IP information for wlan0...dhclient(2258) is already running - exiting. 
This version of ISC DHCP is based on the release available
on ftp.isc.org.  Features have been added and other changes
have been made to the base software release in order to make
it work better with this distribution.
Please report for this software via the Red Hat Bugzilla site:
Comment 1 Harry Krevis 2007-11-11 00:32:12 EST
Created attachment 254221 [details]
error message
Comment 2 Sergio Monteiro Basto 2007-11-12 15:46:28 EST
this is the same bug of #370971 ?
Comment 3 Dan Williams 2007-11-13 11:01:06 EST
You are likely running NetworkManager (turned on by default for LiveCD installs)
and trying to activate the network manually.  Can you see if the NetworkManager
service is turned on, either by going to System->Administration->Services or by

/sbin/chkconfig --list | grep Network

from a terminal?
Comment 4 Sergio Monteiro Basto 2007-11-14 11:32:48 EST
see man wpa_supplicant to find your appropriate driver 

I realize that wpa_supplicant change, we should alter  /etc/sysconfig/wpa_supplicant

# wlan0 and wifi0
# INTERFACES="-iwlan0 -iwifi0"
# ndiswrapper and prism
# DRIVERS="-Dndiswrapper -Dprism"

so here , after comment driver section (with #DRIVERS="-Dwext") and keep my
interface I got wireless working again.
Comment 5 Sammy 2007-11-20 10:24:22 EST
This problem is occuring for ipw2200 too after update from F7 to F8 via
yum. NetworkManager is NOT running.

This problem occurred long time ago  again. It can be solved by removing the
Rate="..." line in /etc/sysconfig/ifcfg-eth1 or whatever your interface is

Comment 6 Sergio Monteiro Basto 2007-11-20 17:41:30 EST
(In reply to comment #5)
> This problem occurred long time ago  again. It can be solved by removing the
> Rate="..." line in /etc/sysconfig/ifcfg-eth1 or whatever your interface is
> called.
yes , removing RATE="..." from /etc/sysconfig/network-scripts/ifcfg-eth1 
removes the message 
Set Mode" (8B06) :
    SET failed on device wlan0 ; Invalid argument
Comment 7 Jonathan Robie 2008-01-04 08:57:22 EST
I had this same problem, but I was not running NetworkManager.

Removing RATE= did not fix the problem.

When I ran NetworkManager, it magically did the right thing and connected for me.
Comment 8 Dan Williams 2008-09-29 22:48:16 EDT
My bad; message is from ifup when trying to run dhclient; it appears the connection is already up.  Over to system-config-network.
Comment 9 Bug Zapper 2008-11-26 03:18:38 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 10 Bug Zapper 2009-01-09 00:08:59 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.