Bug 375541 - Enhancement request: Java Web Start support in icedtea
Enhancement request: Java Web Start support in icedtea
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Joshua Sumali
Fedora Extras Quality Assurance
:
: 322951 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-11 01:04 EST by santiago angel
Modified: 2008-04-18 10:30 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-18 10:30:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description santiago angel 2007-11-11 01:04:50 EST
Description of problem:

Enhancement request: Java Web Start support in icedtea



Version-Release number of selected component (if applicable):

1.7.0.0-0.19.b21.snapshot


How reproducible:
always

Steps to Reproduce:
1.enter in a page with a Java Web Start link in firefox
2.click in a link terminated with .jnlp

  
Actual results:
if only icedtea java version is installed nothing happens
otherwise if another version of java 5 or 6 is installed the link opens in a new
Java Web Start window


Expected results:

open the Java Web Start link in an icedtea java version


Additional info:

there's a open free implementation of Java Web Start in:
http://openjnlp.nanode.org/

i tested the 0.7.1 version in a command line with:

sh openjnlp.sh http://dist.trolltech.com/developer/download/webstart/qtjambi.jnlp

and run successfully

(process executed: /usr/lib/jvm/java-1.7.0-icedtea-1.7.0.0/jre/bin/java
-Djava.ext.dirs=/home/javatest/.jnlp/cache/launcher org.nanode.jnlp.JNLPParser
-internal http://dist.trolltech.com/developer/download/webstart/qtjambi.jnlp )
Comment 1 Lillian Angel 2007-11-22 10:26:38 EST
*** Bug 322951 has been marked as a duplicate of this bug. ***
Comment 2 Lillian Angel 2008-01-14 11:28:49 EST
javaws support has been added. It will be available in the next release.

Assigning this bug to Josh, so he can close it when he is done working on the
netx support.
Comment 3 Lillian Angel 2008-02-13 12:57:32 EST
The first glimpse of webstart support will be in rawhide within the next couple
of days. Release b25.
Comment 4 Joshua Sumali 2008-02-28 13:20:27 EST
While not complete, a lot of Java Web Start support has been added to IcedTea.
Some major new features include verification of signed jars, trusted certificate
storing, system certificate store checking, and provides some services specified
by the jnlp API.
Comment 5 Lillian Angel 2008-04-17 13:23:46 EDT
This will be in the next release of IcedTea
Comment 6 Lillian Angel 2008-04-18 10:30:21 EDT
Building new version into rawhide, should be in tomorrow.

Note You need to log in before you can comment on or make changes to this bug.