Bug 375711 - dhcp: consider shipping more recent version of dhcpd-conf-to-ldap.pl
Summary: dhcp: consider shipping more recent version of dhcpd-conf-to-ldap.pl
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: dhcp   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: David Cantrell
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-11-11 10:55 UTC by Tomas Hoger
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-12 22:35:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tomas Hoger 2007-11-11 10:55:10 UTC
dhcpd-conf-to-ldap script shipped with dhcp packages up to the latest devel
version dhcp-3.1.0-7.fc9 seems to be fairly old.

Upstream dhcp-ldap patch available from Brian Masney's page
(http://home.ntelos.net/~masneyb/) contains updated and improved version (see
contrib directory in the patch) at least as of version of patch for dhcp 3.0.4.

Improvements in new version:
- provides command line arguments to specify basedn / dhcpdn, so it does no
longer need to be changed before use;  therefore it may be possible to move it
from doc directory to e.g. /usr/sbin
- has support for failover configurations, generated ldif file than needs only
limited amount of manual tweaking

Please consider bundling updated script version with dhcp packages.

Comment 1 David Cantrell 2007-11-12 22:35:03 UTC
Updated to the newer conversion script and patch.  The patch available at the
link you provided is written for the old OpenLDAP API.  So while it's newer, I
still had to rewrite a number of things to make it work with the latest OpenLDAP
API.

Comment 2 Tomas Hoger 2007-11-13 08:43:42 UTC
David, thanks for the update!

I wasn't aware of the OpenLDAP API problem, as I was using it some time ago 
with older version of OpenLDAP libs.

Re: "including SSL support" - I've had problem with patch for 3.0.4 with 
respect to SSL support.  Once SSL support was enabled, non-SSL connections 
were no longer working.  Not sure if it's still issue, so treat this note as 
heads-up in case it will break someone's setup.



Note You need to log in before you can comment on or make changes to this bug.